I got codes 83, 84, 85

Joined
Jun 13, 2004
Messages
619
Location
Sacramento Ca.
Ok, so I have tried the search funtion and I cant find what these codes mean. Perhaps I am not looking under the right wording, who knows! Can anyone tell me what the codes 83, 84, and 85 mean? Oh yes, this is a 1993 fzj80 with 240+ miles on her. Thanks, Chans
 

MoJ

Moderator
 
 
Joined
Oct 24, 2003
Messages
3,776
TCM communication
 
Last edited:
Joined
Jun 13, 2004
Messages
619
Location
Sacramento Ca.
I just found my problem and I am now trying to wipe away the tears! So, basically do I need to fix this problem now or can I just let it ride for awhile (make that a long while)? What are the long term problems that could arise if I do not fix this problem? Thanks, Chans
 
Joined
Mar 30, 2003
Messages
1,623
Location
LA, CA
Don't cry yet- from what I remember, Robbie (now powderpig) had a different possible cause for this problem other than a bad ECU. Search.
 
Joined
Jun 13, 2004
Messages
619
Location
Sacramento Ca.
I am still searching but havent found much yet..........other than the new ECU is needed. Feel free to post up a link or something if anyone has an idea, other cause, or what will happen if I dont fix the problem anytime soon. Thanks, Chans
 
Joined
Jun 13, 2004
Messages
619
Location
Sacramento Ca.
medtro said:
This is the latest thread (before you) that I saw with those codes. Hope this helps.

Thanks for the thread, it did explain what is going on. I think?? I might just keep driving it for a while due to the fact that I cant afford to fix it......You think that is ok to do?
 
Joined
Mar 30, 2003
Messages
1,623
Location
LA, CA
Replacing the ECU is expensive. Checking the TPS is not.

Quoting Christo:

"The computer is looking at the idle circuit. So you might think the problem is at the tranny, but more than likely the throttle position sensor is faulty or misadjusted and it is not telling the tcm that the truck is idling. Use the FSM and check and adjust the tps if needed."
 

sethro

 
Joined
Oct 28, 2004
Messages
178
Location
Sonoma,CA
I had the same codes (in addition to 28) on my 93. I cleared the codes (by pulling the efi fuse for at least 15 seconds) and it came back. I called CDan (he rocks!) and decided against spending over $1000 on a new ECM. Found one on www.car-part.com for $250 in Colorado. Just make sure when you order 'new' ECM, it's the updated part #. (89661-60221 , but check w/ CDan to be sure...)


Cool,

seth
 
Top Bottom