code PO420

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, Skimlinks, and others.

Feb 6, 2010
I have a new exhaust system from emspowered and about two months later check engine light on with code # PO420 ( catalyst efficiency below threshold ) Any thoughts ?
Were you getting any codes prior to the new exhaust system?

From what I've read, the P0420 is a generic code and it can be the cats or the O2 sensors. See Troubleshooting P0420 Catalyst Code

I would clear the code and see how fast it comes back. Mine would come and go. Sometimes it was right away and
other times it took 4 months to come back.

Also, did you replace everything (cats, O2 sensors, y-pipe, muffler, tailpipe) with the new EMS system?
I'm getting the same error after having my EMS Powered exhaust installed. Don't get me wrong. The exhaust looks great, sounds great, & the ground clearance is fantastic. I am just having some trouble getting rid of this error. If I had to do it over again, I would buy the EMS exhaust again. I haven't replaced the 02 sensors yet. I think I am not getting a good enough seal at the v-band clamp. Baktasht sent me a replacement clamp free of charge. After installing the error code took a couple weeks to come back. I may try exhaust tape where the two sections come together then apply the clamp on top. Let's keep each other informed so we can both get this issue resolved.
Today I raised the over frame pipe by spacing it up three nuts. I barely tightened the v-band clamp along with adding a second nut. I cranked the motor & no CEL. I'll let you know if & when it comes back.
I spoke too soon. The CEL came back on. I will check for leaks one more time. If I can't find any I guess the 02 sensors are next.
I've had a CEL code from the start. After installation, the truck ran horribly. I took it for its annual inspection right after installation and my mechanic told me the code indicated a tune up was needed. The code apparently indicated incomplete combustion. I never did get the code number from him.

He put in new plugs and all that jazz, the code was gone for about an hour and came right back on. Meanwhile the truck was still running horribly. The idle was too low and spotty - that is it ran like it was missing. And the stink coming out of the back end was quite strong, like a failing cat. I took it over to the Toyota dealer this time and had them plug it in and they told me it needed O2 sensors. I ordered some from CDan and installed them myself. The truck still runs poorly at and just off idle, and the cat is still spewing a stink.

Not certain what to try next as there are no leaks either. Thoughts?
Henry, the plugs that the mechanic put in, were they factory? You may want pull them and check the gap, additional what was included in there so called "tune-up"?

Also have you checked for vacuum leaks or to see whether or not the main intake tube is cracked or split. Systematically go through each area of the engine and its components to eliminate systems that are in good shape.

If it still has the code, I suggest having it pulled to determine which one it is, then report back and also do a search of the forum to see what possible solutions come up.

Good luck
Last edited:
Henry, your cats may also be shot and in need of replacement. Plenty of aftermarket options available, a search will yield loads of info.​
I had the local dealership diagnose the cause of my CEL. The end result is I'm out $45 & I still don't know. According to them my 02's are fine. They think it is the cat on my exhaust. To try to eliminate the possibility of a leak I used hi temp exhaust repair tape under the clamp between the 2nd o2 & the muffler. I am pretty sure this is not the location of a leak. After doing this I cleared the CEL for a road test. 8 miles later the CEL came back on. Next I tried an idle test, I let the exhaust cool, reset the CEL, then ran the motor for a little over an hour in the driveway with no CEL returning (go figure). I bet before I get home from work tomorrow the light will be back on. I guess it has something to do with the cat getting hot enough. Hope this info help someone in determining what might be causing this error that has some of us pulling our hair out. :)
Got it fixed. The problem with mine ended up being a leak at one of the y pipe gaskets.

Users who are viewing this thread

Top Bottom