'Whoosh" when I remove gas cap/Supercharger/EGR Code (1 Viewer)

Joined
Sep 23, 2009
Messages
134
Location
Hurst, Texas
Ah, too many things to learn and I'm too stinkin' old!

For months (OK, a couple or three years), when my tank gets low and I pull in to fill up, when I unscrew the gas cap, I get a mighty "whoosh-ing" of air (vapor?) from the tank.

Question #1: What's up with that?

Next... My TRD supercharger installation was completed last Friday... it's a fourteen-year-old-new-truck! Today, while on my way home from a gormet meal at my local Subway, I got a CEL. Drove over to the installer to put the code-reader on it and found it was "Insufficient EGR flow" (or some such verbaige).

He cleared the code and I drove home (all four miles of it) completely code-less. We agreed that the code was not life-threatening, and agreed to see what happens next (!)

Question #2: Could the "whoosh" and the CEL be related?

Thanks Gurus!

Rob
 
Joined
Sep 25, 2009
Messages
160
Location
DC
i get the whoosh as well, i think its just a pressure equalization since you had gas in there and now its gone and makes a vacuum to some degree
 
Joined
Sep 23, 2009
Messages
134
Location
Hurst, Texas
i get the whoosh as well, i think its just a pressure equalization since you had gas in there and now its gone and makes a vacuum to some degree

Hmmmmmmmmm, you just may be right. I've been thinking that it was "whoosh-ing out" (pressure) and not "whoosh-ing in" (vacuum).

Rob
 
Joined
Jun 9, 2006
Messages
2,590
Location
Spokane WA
I think the whoosh might be due to the charcoal canister being full of fuel secondary to overfilling the tank.
 

retrofive

retrò
SILVER Star
Joined
Jan 6, 2008
Messages
15,308
Location
meridionale oregon
I think the whoosh might be due to the charcoal canister being full of fuel secondary to overfilling the tank.

x2 most of this sounds typically of a 80, check the charcoal canister.

EDIT: normal but the EGR. Have you tested any of the EGR system or did the shop that installed it? Could be a couple different items there.
 

S.CarolinaFZJ80

SILVER Star
Joined
Oct 4, 2008
Messages
4,256
I had the same EGR code 0401 pretty regularly. It used to come back on every four trips. After installing my SC, I replaced the gasket between the EGR and upper intake plenum and no CEL in about a dozen short trips.
 

Users who are viewing this thread

Top Bottom