Questions on spark plugs and timing w EFI

Crush 4

GOLD Star
Joined
Feb 14, 2019
Messages
885
Location
Motor city
Visit site
Questions for the experts. I was fiddling w the 75-40 today and wondered if the timing should be set any different when running a Howell EFI? Also, if anyone out there has a lot of experience w tuning the Howell system I would love to talk w you as I have a few questions on “ tuning” it.

Also the PO put platinum plugs in. Are these best for overall performance or should I run something else?

Thx
 
Last edited:

Crush 4

GOLD Star
Joined
Feb 14, 2019
Messages
885
Location
Motor city
Visit site
The tune in the efi dictates where timing is set. Howell should tell you that number. Does yours have electronic timing control?
I’m a bit of a newb to this as it was put on by PO. I’m trying to sort through what I have
Which I believe is this... I’ll dig into manuals as well

A8A365A4-EA15-4EB8-B890-875B2D89CA3E.png
 
Joined
Jan 17, 2005
Messages
5,870
Location
Southern Colorado
Visit site
I would install the original style plugs in any 2F rather than any plantinum. My AFI TBI (which uses GM components) had me set the timing at TDC, and it runs best there. I tried advancing it (using their suggested method) and it did not run as well. Your elevation (above sea level) could play a role in this, too. Best to get all the docs and read up on your particular system. There are some Howell threads if you search - or call the company.
 

Users who are viewing this thread

Top Bottom