Minor setback on drivetrain swap. (1 Viewer)

Joined
Dec 30, 2007
Messages
203
Location
N.Las Vegas
Doing 5.3 vortec with 4l60e trans and had the trans rebuilt to basically a race spec tranny minus servos to prevent hard shifting. However when I fired it up this weekend the tranny did not really shift into any gear. I jacked up the rear end and when put in reverse still wants to go forward in neutral and drive it goes forward but I can grab the driveshaft and stop it by hand. Checked for output to cooler and only get about a 1/4 quart in a min. Called my tranny guy and he is headed out here on Tue. Just wondering what you tranny guys know or if anyone has seen this before.
 
Joined
Dec 15, 2008
Messages
1,154
Location
Ruston, LA
I know very little about transmissions but you might not want to run it much more if it's not pumping fluid; I don't think it takes much to burn'em up.
 
Joined
Feb 28, 2008
Messages
1,390
The only way to check fluid is running in park. Unless its running in park its going to show full when its a few quarts low and wont do anything. Other than that its probably going to be something fairly serious.
 
Joined
Dec 30, 2007
Messages
203
Location
N.Las Vegas
Well, found my issue. When I put the torque converter in I didn't pay attention and cracked the ears off the pump where the torque converter meets it. Was able to look inside the seal and see both ears gone and a chunk lodged in the seal where the pump is. So back to the tranny guy for more upgrades.
 
Joined
Dec 30, 2007
Messages
203
Location
N.Las Vegas
Couple pics of the damage got her back together this morning and hopefully get the exhaust welded up and ready for a test drive by next weekend.
100_2079.jpg
100_2080.jpg
 

Users who are viewing this thread

Top Bottom