93 fzj80 going dead - HELP!!

Joined
Jun 6, 2005
Messages
7
OK. Yesterday I changed the oil and air filter and also did some cleaning underneath and on the engine. Used SuperClean for degreaser and hose to wash off and was careful. I did unplug the center wire on the distributor cap to get at the oil filter easier.

After all was done it would hardly idle finally cleared up but going dead instantly when put in reverse also goes dead if you are coming to a stop when in Drive. Freakiest of all is it will go dead when turning left more than if going straight or turning right - left kills it for sure along with reverse. Just won't hardly run in reverse must keep foot on brake and gas to make it move.

Idles better with air con on than with it off.

Good news is the oil leak seemed to stop when switched to 0W-40 as suggested here - Thanks!
 
Joined
Feb 7, 2005
Messages
141
Look at all of your rubber hoses especially the air cleaner to TB for cracks and what nots; is your PVC connected?
 

Beowulf

 
 
Joined
Mar 27, 2003
Messages
12,524
Location
Somewhere in the foothills...
ultimauk said:
Look at all of your rubber hoses especially the air cleaner to TB for cracks and what nots; is your PVC connected?
I agree with Ultimauk. When you replace the air filter you have to be careful with the removal of the hose between the canister and the intake. This hose had been the source of numerous problems identical to yours; frequently following an AF replacement or inspection.

The proper way to change the AF is to loosen the hose clamp on the canister side of the hose, then gently remove the lid of the air canister, replace the filter, and reinstall.

-B-
 
Top Bottom