What is this? Help!

Joined
Oct 29, 2007
Messages
684
Location
Birmingham, AL
I was removing my oil filter with the assistance of a removal strap and when I went back to install the new filter I saw this wire hanging. It appears that the plastic connector broke. Looking through the Electrical Wiring manual, it appears to be the crank shaft position sensor. Sounds important. The connector fit back together, but I am not sure it is going to hold.

Can anyone help?

(By the way, this is not a picture of my truck. I pulled the picture from this thread: https://forum.ih8mud.com/80-series-tech/294501-trick-removing-stubborn-oil-filter.html)
111_1182.jpg
 

Wrench

One Bashed Up 80
Joined
Mar 27, 2003
Messages
4,605
no the crank position sensor would be in the block not in the head like that one. I'd say it is a coolant temp sensor.
 

BamaHeel

Intergalactic Champion
Joined
Sep 15, 2010
Messages
1,961
Location
Birmingham
I think its a dicfur
 
Joined
Aug 10, 2009
Messages
816
Location
Puerto Rico
+1 I think is a coolant sensor since it's only got 1 wire.

Or it could be Updoc.
:hmm:
 

94SRUNNER

GOLD Star
Joined
Oct 9, 2006
Messages
4,256
Location
Dayton, OH
[STRIKE]Yes, I am farily certain it is the #1 knock sensor.[/STRIKE]
 
Last edited:

powderpig

SILVER Star
Joined
Jul 12, 2005
Messages
1,029
Location
Boulder Foothills, CO
The picture you are showing is a coolant sensor. So if the picture is correct, then no knock sensor is broken. The knock sensors are in two positions on the block, not the head. The knock sensor has a one wire connector going to it as well. It is almost in line but a little above the oil filter Typically between 2-3 cylinders as the other one is between 5-6 cylinders.
 

94SRUNNER

GOLD Star
Joined
Oct 9, 2006
Messages
4,256
Location
Dayton, OH
I stand corrected. Thanks for clearing this up Robbie.
 
Last edited:
Joined
Oct 29, 2007
Messages
684
Location
Birmingham, AL
Ok. Here is an actual picture from my truck and in the picture the sensor has been pulled out of it's housing. It appears the plastic clip that holds it in place is broken, but the sensor stays in place when driving.

So...knock? coolant?

If it falls out or disconnects while driving, is it just going to throw a code or something else like eject the passenger seat?
IMG_20110525_193942.jpg
 
Joined
Oct 29, 2007
Messages
684
Location
Birmingham, AL
The picture you are showing is a coolant sensor. So if the picture is correct, then no knock sensor is broken. The knock sensors are in two positions on the block, not the head. The knock sensor has a one wire connector going to it as well. It is almost in line but a little above the oil filter Typically between 2-3 cylinders as the other one is between 5-6 cylinders.

Powderpig...thanks for the reply.

Is there any negatives if it falls out while driving?
 

Users who are viewing this thread

Top Bottom