Transpo IN554 V Reg made in China??

Joined
Aug 4, 2007
Messages
75
I just got a replacement Transpo IN554 VR and it seems they are now made in China. It definitely looks lower quality than the Transpo In554 I am replacing.

Anyone have any experience with these Chinese units?
 

lostmarbles

SILVER Star
 
Joined
Sep 3, 2007
Messages
8,901
Location
New Zealand
I just got a replacement Transpo IN554 VR and it seems they are now made in China. It definitely looks lower quality than the Transpo In554 I am replacing.

Anyone have any experience with these Chinese units?
I wouldn't be surprised if the OEX-brand (Australia) RGX2032 solid-state regulator I've just bought also originated from China.

Perhaps you should take some figures with a voltmeter and post up results of how it performs?

That's what I intend to do with my OEX unit (when I eventually get around to it). I'll do a comparison with my original ex-factory regulator - which is still performing well. ....................PS: I just bought the new regulator as a spare and because it appears to be a simple plug-in replacment that even mounts in the original bolt-holes.)

:cheers:
 
Joined
Aug 4, 2007
Messages
75
Hey Lostmarbles - I'm not quite yet at the electrical-testing level yet but I see I am heading that way.

Do I just get a voltage tester?
 

lostmarbles

SILVER Star
 
Joined
Sep 3, 2007
Messages
8,901
Location
New Zealand
Hey Lostmarbles - I'm not quite yet at the electrical-testing level yet but I see I am heading that way.

Do I just get a voltage tester?
A cheap multimeter like this would do the trick and then just place it across your battery terminals (on the correct DC voltage setting and with the probes on the appropriate terminals of course):

voltageglow1.JPG

A good battery should read about 12.6V after a "settling period" (mine reads 12.44V here but I'd already been draining it by doing a few "glows" - and glowplugs do draw a lot of current!) and around 13.6V if you were to check it again after "going for a reasonable drive" or "after charging via a plug-in mains-powered charger". (In case this isn't clear, - both these figures are for "Engine/charging OFF".)

So when your engine is on (and running) you should be able to measure a higher voltage than either of these values (more than 13.6V) if your battery is going to be getting charged by your alternator.

Measuring 14.4V while your engine is running would be "about normal" but it should NOT rise beyond 14.7V. (If it does, then your new chinese regulator is probably unsatisfactory.)

:cheers:
voltageglow1.JPG
 
Top Bottom