Transpo IN554 V Reg made in China??

Discussion in '40- & 55-Series Tech' started by GreensKeeper76, Feb 12, 2009.

  1. GreensKeeper76

    GreensKeeper76

    Messages:
    75
    Likes Received:
    0
    Joined:
    Aug 4, 2007
    I just got a replacement Transpo IN554 VR and it seems they are now made in China. It definitely looks lower quality than the Transpo In554 I am replacing.

    Anyone have any experience with these Chinese units?
     
  2. lostmarbles

    lostmarbles SILVER Star

    Messages:
    8,905
    Media:
    100
    Albums:
    2
    Likes Received:
    1,472
    Joined:
    Sep 3, 2007
    Location:
    New Zealand
    I wouldn't be surprised if the OEX-brand (Australia) RGX2032 solid-state regulator I've just bought also originated from China.

    Perhaps you should take some figures with a voltmeter and post up results of how it performs?

    That's what I intend to do with my OEX unit (when I eventually get around to it). I'll do a comparison with my original ex-factory regulator - which is still performing well. ....................PS: I just bought the new regulator as a spare and because it appears to be a simple plug-in replacment that even mounts in the original bolt-holes.)

    :cheers:
     
  3. GreensKeeper76

    GreensKeeper76

    Messages:
    75
    Likes Received:
    0
    Joined:
    Aug 4, 2007
    Hey Lostmarbles - I'm not quite yet at the electrical-testing level yet but I see I am heading that way.

    Do I just get a voltage tester?
     
  4. lostmarbles

    lostmarbles SILVER Star

    Messages:
    8,905
    Media:
    100
    Albums:
    2
    Likes Received:
    1,472
    Joined:
    Sep 3, 2007
    Location:
    New Zealand
    A cheap multimeter like this would do the trick and then just place it across your battery terminals (on the correct DC voltage setting and with the probes on the appropriate terminals of course):

    voltageglow1.JPG

    A good battery should read about 12.6V after a "settling period" (mine reads 12.44V here but I'd already been draining it by doing a few "glows" - and glowplugs do draw a lot of current!) and around 13.6V if you were to check it again after "going for a reasonable drive" or "after charging via a plug-in mains-powered charger". (In case this isn't clear, - both these figures are for "Engine/charging OFF".)

    So when your engine is on (and running) you should be able to measure a higher voltage than either of these values (more than 13.6V) if your battery is going to be getting charged by your alternator.

    Measuring 14.4V while your engine is running would be "about normal" but it should NOT rise beyond 14.7V. (If it does, then your new chinese regulator is probably unsatisfactory.)

    :cheers:
    voltageglow1.JPG
     
  5. GreensKeeper76

    GreensKeeper76

    Messages:
    75
    Likes Received:
    0
    Joined:
    Aug 4, 2007
    Sweet. Many thanks for taking the time to explain this. Time to add another tool to the garage!
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.