Missing part of instrument cluster

Joined
Jan 18, 2006
Messages
854
Location
Michigan/Costa Rica
I took my instrument cluster apart to clean and repaint the needles on my HJ45. It appears that someone prior had worked on it as it is missing the part that has the "OIL", "FUEL", "TEMP", and "AMPS" symbols on it as shown in the photo below. Is that a separate part? Does anyone have pictures of the part itself? Is that part available anywhere?
1640529771356.png
 

WarDamnEagle

SILVER Star
Joined
May 20, 2007
Messages
6,026
Location
Riyadh and Auburn
I believe the part number is 83134-60070. Appears to be discontinued. That part number is for a J07 cluster which, FWIW, didn't use symbols. It had OIL, FUEL, TEMP and AMP spelled out where those symbols are. Someone has mixed and matched parts in the cluster shown above.

Edit: I must have been asleep when I wrote this. Apologies to the OP. That is the correct part number though for the part you are looking for.
 
Last edited:
Joined
Jan 18, 2006
Messages
854
Location
Michigan/Costa Rica
I believe the part number is 83134-60070. Appears to be discontinued. That part number is for a J07 cluster which, FWIW, didn't use symbols. It had OIL, FUEL, TEMP and AMP spelled out where those symbols are. Someone has mixed and matched parts in the cluster shown above.
Thanks for the info. I can live without it for the time being and maybe can source a used one eventually for a scrapped cluster.
 

WarDamnEagle

SILVER Star
Joined
May 20, 2007
Messages
6,026
Location
Riyadh and Auburn
Well you can still buy a new J01 cluster which has that part. The J01 cluster used the symbols and was an earlier, 5 digit odo model. It's not entirely clear to me which cluster you have. Again, the photo you posted is a mixture of different years.

Edit: Still asleep.

 
Last edited:
Joined
Jan 18, 2006
Messages
854
Location
Michigan/Costa Rica
Well you can still buy a new J01 cluster which has that part. The J01 cluster used the symbols and was an earlier, 5 digit odo model. It's not entirely clear to me which cluster you have. Again, the photo you posted is a mixture of different years.

If I can't source just the 83134-60070 part sometime in the near future, I would rather purchase a Dakota digital cluster than invest $200 to $300 for a new OEM unit.

I certainly appreciate your input.
 

WarDamnEagle

SILVER Star
Joined
May 20, 2007
Messages
6,026
Location
Riyadh and Auburn
If I can't source just the 83134-60070 part sometime in the near future, I would rather purchase a Dakota digital cluster than invest $200 to $300 for a new OEM unit.
Just to be clear so I'm not misleading you, the part number 83134-60070 doesn't have the symbols; it has the words. The earlier gauge that I referenced above on Partsouq has the symbols and it appears the correct part number for the panel with the symbols is 83134-60082. It is also discontinued as far as I can tell. If I knew what year HJ45 you were working with I could tell you the correct instrument cluster, if it matters to you.

Edit: Just totally wrong.
 
Last edited:

Gun Runner 5

First and Final Warning!!
SILVER Star
Joined
Oct 22, 2009
Messages
18,580
Location
Thomasville, GA
Just to be clear so I'm not misleading you, the part number 83134-60070 doesn't have the symbols; it has the words. The earlier gauge that I referenced above on Partsouq has the symbols and it appears the correct part number for the panel with the symbols is 83134-60082. It is also discontinued as far as I can tell. If I knew what year HJ45 you were working with I could tell you the correct instrument cluster, if it matters to you.
Do the “words vs symbols” reflect a year model or the region in which the 40 Series was sold?
 

WarDamnEagle

SILVER Star
Joined
May 20, 2007
Messages
6,026
Location
Riyadh and Auburn
Do the “words vs symbols” reflect a year model or the region in which the 40 Series was sold?
These are both General Countries clusters (KM only). Without doing an exhaustive search, I would say the J01 cluster with words is something like late 70s through 80 (or maybe 81?) and the J07 cluster with symbols is later (so 80 or 81 through 84). My 12/82 (Edit: Corrected year) FJ45 Troopy has the J07 cluster.

Edit: So I finally managed to post something correct today. Apologies again to the OP.

3DA3BC4C-B2A3-41C5-86A7-CD48D6C4A445.jpeg


81C41D19-B9AC-4BFD-9682-C9744B612B5F.jpeg
 
Last edited:
Joined
May 15, 2005
Messages
9,802
Location
Ladysmith
I took my instrument cluster apart to clean and repaint the needles on my HJ45. It appears that someone prior had worked on it as it is missing the part that has the "OIL", "FUEL", "TEMP", and "AMPS" symbols on it as shown in the photo below. Is that a separate part? Does anyone have pictures of the part itself? Is that part available anywhere?
Sometimes the best thing to show a picture of is the part you have first. Then post a pic of a part
indicating what you are missing.
So have you got a pic of your instrument cluster? Just cause swapping a digital cluster doesnt have
to happen. Lots of old gauge clusters kicking around.
 

Gun Runner 5

First and Final Warning!!
SILVER Star
Joined
Oct 22, 2009
Messages
18,580
Location
Thomasville, GA
These are both General Countries clusters (KM only). Without doing an exhaustive search, I would say the J01 cluster with words is something like late 70s through 80 (or maybe 81?) and the J07 cluster with symbols is later (so 80 or 81 through 84). My 12/83 FJ45 Troopy has the J07 cluster.

Edit: So I finally managed to post something correct today. Apologies again to the OP.

View attachment 2875351

View attachment 2875352
Thanks ….. my late ‘82 model has symbols which I guess makes sense.
 

ToyotaMatt

Factory Focus-Point Mind-Set Approach
Supporting Vendor
GOLD Star
Joined
Aug 12, 2007
Messages
19,730
Location
EAST COAST
Website
vintageteqparts.com
I took my instrument cluster apart to clean and repaint the needles on my HJ45. It appears that someone prior had worked on it as it is missing the part that has the "OIL", "FUEL", "TEMP", and "AMPS" symbols on it as shown in the photo below. Is that a separate part? Does anyone have pictures of the part itself? Is that part available anywhere?View attachment 2875162


B242B27A-700C-4659-A424-FD27FF000582vintagetewp[arts .jpg
 
Joined
Jan 18, 2006
Messages
854
Location
Michigan/Costa Rica
My HJ45 is a 1980 model. It was sold in Costa Rica originally so the speedometer is in KM. It does not have the dual scale markings. The cluster has a 30 amp gauge and a 5-digit odometer, none of which could be original. My main reason for wanting to find the missing part is to prevent the back lighting from shinning through. It is rather distracting while driving at night especially as the Costa Rican truck didn't come with at instrument light dimmer.
 

65swb45

Elder Statesman
Supporting Vendor
Joined
Apr 14, 2004
Messages
31,750
Location
818-953-9230
Website
www.marksoffroad.net
If you have a stateside shipping address I would happily ship you a used one for free, with a minimum qualifying order. It would look like the one in the 73-78 illustration @ToyotaMatt so kindly provided.

There’s a stack of them around here. :grinpimp:
 
Last edited:
Joined
Jan 18, 2006
Messages
854
Location
Michigan/Costa Rica
If you have a stateside shipp address I would happily ship you a used one for free, with a minimum qualifying order. It would look like the one in the 73-78 illustration @ToyotaMatt so kindly provided.

There’s a stack of them around here. :grinpimp:
Thanks you for the kind offer which I will take you up on once I get back stateside. I expect to be back some time in April and will have a list of needed parts at that time.
 

ToyotaMatt

Factory Focus-Point Mind-Set Approach
Supporting Vendor
GOLD Star
Joined
Aug 12, 2007
Messages
19,730
Location
EAST COAST
Website
vintageteqparts.com
Thanks you for the kind offer which I will take you up on once I get back stateside. I expect to be back some time in April and will have a list of needed parts at that time.


i WILL ship International provided we use ONLY FED-EX and FULLY Insured THU fed ex express only ,


i have this
KUSTOM one off Proto-Type SEMA-SPEC design , i dialed in , it DOES have the 30 AMP meter you mention , it 100% Bench tested also , its a 12V volts unit


PM me Please for further details ..........



00DB108C-7179-469F-8142-100CBBA9251C.jpeg
498E2493-62B9-464A-9761-2C3D0CEFBAD1.jpeg
 

Users who are viewing this thread

Top Bottom