is this an oem emblem (1 Viewer)

Landpimp

GOLD Star
Joined
Mar 14, 2003
Messages
16,069
Location
Gig Harbor WA
 
 
 
yes......kinda, the originals were a cream color.....I just bought a new one. that one is prolly sanded down or something
 
Joined
Jul 2, 2002
Messages
1,373
Location
New Hampshire
 
 
 
 
It doesn't look stock to me, unless the diesel's used a different one. My new one looks just like what landpimp posted. My old one was totally weathered, all silver, even in between the letters. But it didn't look like the one on that truck at all. The letters look too big, and flat. Looks good, just doesn't look stock.
 

Landpimp

GOLD Star
Joined
Mar 14, 2003
Messages
16,069
Location
Gig Harbor WA
 
 
 
yeah, something is differnet about it, maybe it off a fj60?

ken_79-fj40 said:
It doesn't look stock to me, unless the diesel's used a different one. My new one looks just like what landpimp posted. My old one was totally weathered, all silver, even in between the letters. But it didn't look like the one on that truck at all. The letters look too big, and flat. Looks good, just doesn't look stock.
 

esh

SILVER Star
Joined
Apr 22, 2003
Messages
2,054
Location
Oregon
 
 
 
Doesn't appear OEM. Diesels had the same as gassers (my BJ42s and '79 FJ40 are all identical)-

 

Landpimp

GOLD Star
Joined
Mar 14, 2003
Messages
16,069
Location
Gig Harbor WA
 
 
 
thing is.......I have seen that emblem someplace on something.......just can't remember where or what?

maybe just a Toyota truck?
 

rusty_tlc

Dain Bramaged Member
Joined
Jun 23, 2005
Messages
13,926
Location
Reno, NV
 
 
 
Landpimp said:
thing is.......I have seen that emblem someplace on something.......just can't remember where or what?

maybe just a Toyota truck?
Maybe on the Rod Millen Retro Cruiser? I can't find a good close up of the grill.
 
Joined
Nov 14, 2004
Messages
3,399
Location
PNW
 
 
 
Doesn't the whole bib look wrong? I'm not sure about the '79+ but the "vents" at the bottom below the opening that contains the emblems on earlier ones has an indented area to the side of each of the vent holes. That one looks perfectly flat from here.

Ditto the 'toyota' emblem looks wrong, too flat also.
 

Landpimp

GOLD Star
Joined
Mar 14, 2003
Messages
16,069
Location
Gig Harbor WA
 
 
 
I think the bib looks correct for 79+

79+ bib(this is a OEM emblem.......faded to white)




honk said:
Doesn't the whole bib look wrong? I'm not sure about the '79+ but the "vents" at the bottom below the opening that contains the emblems on earlier ones has an indented area to the side of each of the vent holes. That one looks perfectly flat from here.

Ditto the 'toyota' emblem looks wrong, too flat also.
 

nuclearlemon

not an addict
Moderator
Joined
Jan 30, 2003
Messages
16,402
Location
windy wyoming
 
 
 
is this that 84 from saudi arabia...maybe non us emblems are different? i agree on oem milled down and polished though.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom