Instrument lights are dead. How to diagnose?? (1 Viewer)

Joined
Jun 4, 2015
Messages
667
Location
Reno ,NV
 
Hello everyone,

Last week I got super bogged down with installing SLEE's upgrade and aux harness. For whatever reason the version I received had the wiring color backwards from what was in the instructions. According to Slee, went I hooked up the aux harness incorrectly it sent power backwards through the harness. The result was my gauge lights (RPM and Speedo) would increase greatly in brightness when the switch was pushed on. It would also trigger the headlights.

Here is what I have tried so far:
Well after playing around with this for a bit the gauge lights will not turn on. I tested the Rheostat for continuity and it seems fine. I checked all the fuses in the dash fuse block. Nothing was blown. I tried jumping the plug that connects to the rheostat, still no dice. Are there any other fuses or relays I should check. The most likely Issue I can think of is that I burnt out the bulbs. Been meaning to replace them all anyway and get my "D" light back but don't want to go on a wild goose chase before making sure that's the actual problem.

Any advice??
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom