Howell Tbi troubleshooting questions and HELP

Joined
Jul 12, 2002
Messages
2,242
Location
McKinney, Texas
Website
www.lslc.org
I had similar issues with a Howell setup on my old F150 (300 I6). I determined that it was starving for fuel when you accelerated. I put a gopro under the hood with the air cleaner off so I could watch what it was doing. Mine turned out to just be a dirty fuel filter. I also routed the fuel line in the engine compartment to run down into another fuel filter just before the TB. It acts as a little reservoir and keeps it from starving.
Another helpful tool is to get an ALDL cable and use something like TunerPro RT.
 

Crush 4

GOLD Star
Joined
Feb 14, 2019
Messages
902
Location
Motor city
I had similar issues with a Howell setup on my old F150 (300 I6). I determined that it was starving for fuel when you accelerated. I put a gopro under the hood with the air cleaner off so I could watch what it was doing. Mine turned out to just be a dirty fuel filter. I also routed the fuel line in the engine compartment to run down into another fuel filter just before the TB. It acts as a little reservoir and keeps it from starving.
Another helpful tool is to get an ALDL cable and use something like TunerPro RT.
Love the GoPro idea, nice!
I’ll look into Tunerpro
Thx for the ideas!
 

Crush 4

GOLD Star
Joined
Feb 14, 2019
Messages
902
Location
Motor city
Another question, is it normal to hear a “swoosh” sound when releasing the gas cap?
 

Users who are viewing this thread

Top Bottom