A/C froze up on road trip??? (1 Viewer)

Joined
Apr 15, 2013
Messages
103
Location
Atlanta, GA
So was driving back from Charleston, SC to Atlanta this weekend in my stock '04. Normal summer heat and humidity. A few hours into the trip the AC started "feeling" warmer but really was less airflow from vents. Fan was blowing like normal. Eventually airflow went to basically nothing. Fan still running full blast, switching modes did nothing, changing vents did nothing, air was still cold but just no flow. Finally just opened windows and turned off until rain came about 30 mins later. Turned back on for kicks and sure enough, more air flow and seemed better. Almost positive the evaporator froze up and blocked the air from passing through. Never ever happened before in my 7+ yrs. A/C works fine around town and no leaves or garbage in fan assembly.

This ever happened to anyone else? I can't believe this is "normal" so what would you check first? Again, works fine around town and feels plenty cold. Rear AC works fine too.
 
Joined
Jul 18, 2020
Messages
46
Location
VA
Coils freezing over can be an issue in the HVAC world. I've heard of it happening in vehicles too but never experience it myself. When you had it turned off it allowed the coils to return to a functional state again. Apparently this can be caused by having low refrigerant in the system, although I've been told it can happen if you have the A/C on a low setting for a long time.
 

Users who are viewing this thread

Top Bottom