77 USA FJ40 wiring question/identification

Joined
Jun 30, 2015
Messages
300
Location
Santa Rosa Beach, FL
I’m wiring the 77 USA FJ40. I have sniper EFI and DUI distributor. Going to route the power to the distributor from battery via a relay. WIll trigger relay with switched 12V from black/yellow wire that was originally on passenger side coil. I have a few questions about things in this general area.

First i need to identify the silver box (just to the left of red battery cable in picture below) that was bolted to passenger side fender. Its got a brown plug , and I don’t know if I can pull it or do I need this connected?

Second, there is a resistor (i think thats what it is) with light blue wire that was originally attached to the ignition coil and black/yellow 12V coil wire. Do I need to keep this installed? And where should I connect the ring terminal ? It appears one end plugs into a wire spliced into the 12V ignition wire. If i need to keep this, i’m not sure where to attach the other end with black wire and the ring.

Your help is appreciated.

2660FE2D-183F-4610-9C9D-35CEFACE6656.jpeg


F134899D-AD22-4D64-B528-0AE4F62F6130.jpeg


76A43637-6AEB-4A1A-B04A-43D2D2065B43.jpeg
 

knuckle47

SILVER Star
Joined
Apr 25, 2022
Messages
320
Location
New Jersey
@Aircooled1 im following along with you on your Sniper Install. Bought mine back in June from Mosley Motors but it still sits in the box until the garage is finished. I am guessing we have the same DUI distributor. Where are you mounting the coolant temperature sensor?
 
Joined
Jun 30, 2015
Messages
300
Location
Santa Rosa Beach, FL
@Aircooled1 im following along with you on your Sniper Install. Bought mine back in June from Mosley Motors but it still sits in the box until the garage is finished. I am guessing we have the same DUI distributor. Where are you mounting the coolant temperature sensor?
I put the coolant sensor in the drain position on the side of the block . The sniper is amazing it drives like new . You’re going to like it.
 
Joined
Jun 30, 2015
Messages
300
Location
Santa Rosa Beach, FL
Here’s a pic of the engine bay before i put the vintage AC system in. I’ll get a pic with the ac completed shortly. I left it at the shop to get charged w/ 134. The install was not as bad as i suspected. Took me all weekend though. Looks really clean when its done. Here’s a few other pics Of cruising the area with a smooth running sniper‘ed FJ40.

3DA92957-2272-4498-ABEF-2115BD29D769.jpeg


4A72BB7E-51D8-4CE4-9B15-2926179C5501.jpeg


9CEC1C57-D4B1-4433-BEFB-796F96FAB754.jpeg
 

Users who are viewing this thread

Top Bottom