1 hour + $9.96 = Gumby antenna

tominboise

SILVER Star
Joined
Dec 17, 2004
Messages
1,046
Location
Boise, Idaho
 
 
 
My power antenna launched itself out of the fender yesterday in the Lowes parking lot. It's especially funny in that I had been telling my wife about how the power antenna's can be trouble in the 80 series, and that I expected mine to go out "sometime". Then when she and the kids were waiting for me to cross the lot and pick them up in front of the store - out comes the mast and rolls across the hood.......

Anyway, stopped at the local schucks and bought a short rubber replacement antenna. It took about 1 hour to R&R the OEM motor, antenna lead and dash switch pack, and install the replacement. I had a blanking plate left over from my CDL switch install, so it looks factory. It seems to work great in the garage - we will see how it does on the road. I have the CD player for times of no reception. The only thing left to do is to pack a little "monkey @&@&@&@&" around the lead where the bulkhead grommet went.

All in all, basically a :banana: job, I think.....

Now time for lots of :beer:

Tom
 

tominboise

SILVER Star
Joined
Dec 17, 2004
Messages
1,046
Location
Boise, Idaho
 
 
 
OK, here is how it looks:



And a close up:



On second thought, I think i will split the grommet and try to reinstall it, rather then packing the hole with goo. Other then that, the radio works great.....

Tom
 
Last edited:

spartan

SILVER Star
Joined
May 30, 2005
Messages
1,032
Location
Secesh
 
I restuffed my motor once and replaced the entire unit once. If it ever craps out again I'm going with a fixed mount on the bull bar and plug the factory hole.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom