Transfer case problem (1 Viewer)

Joined
Feb 2, 2008
Messages
1,710
Location
Palm Harbor, Florida
 
Went wheeling today and my T-case would not stay in low, it would go into high but kept popping out. Anyone have any ideas? It was rebuilt last year and really hasnt been used much since the rebuild.
 
Joined
Nov 16, 2004
Messages
843
Silly as it may sound; check left engine mount (under smog pump).

If engine 'lifts' when applying torque (climbing steep hill for example) ; engine/tranny/xfer moves. shift lever bumps shift gate & goes to N.


Also note, (mine did it) if I pushed into Low xfer too hard, I'd pass Low & end up out of gear (i.e., neutral)
 

IndianDoc

Crazy old Biker
Joined
Mar 8, 2008
Messages
2,106
Location
Sumter SC
I just put new mounts on last year. I will look again and check if its broken again.
Hope it is nothing serious with the colornal. Any more dirty pics. still LMAO Doc:D Those 5 items you want should be ready some time week after next unless there is a manufactoring snafu. Luck. :)
 
Joined
Feb 2, 2008
Messages
1,710
Location
Palm Harbor, Florida
 
It turns out it is the springs on the Xcase- I need to get some stronger ones and problem should be solved- dont even have to drop the case. Will update once completed. Thanks all for the help.
 
Joined
Feb 6, 2008
Messages
436
Location
Bakersfield CA.
 
I was going to say too, look at rubber boot. (inner-outer)
my inner boot was the problem.
all i had to do was to trim it, and no probems since.!
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom