Low power on new Rebuilt 13BT Engine (1 Viewer)

Joined
Jun 14, 2009
Messages
145
Location
Ottawa, Ontario
 
 
I have just rebuilt a 1989 BJ 74 13BT engine. It appears to have less power than my BJ70 3B non turbo had? The engine rebuilder has a great reputation and did an excellent job on my 2H engine a few years back, so I doubt that a mistake was done there. Here are some stats that may assist, Turbo spools up very fast and peaks at 9-10PSI, EGT's come up very fast as well Engine sounds normal, no vibrations, nice stable idle, no smoke . However at 95 to 100Kmh, EGT are close to 1200 and will climb to 1400 if pushed past this speed. While the rebuilder marked the injection pump houseing mounting to engine, could improper timeing cause high EGT, high Boost and low power? Any assitance would be greatley appreciated and perhaps guide me as to where I should be looking. :bang:
 
Joined
Jun 14, 2009
Messages
145
Location
Ottawa, Ontario
 
 
Low power on 13BT

Thanks for the feedback John, the 10 Psi boost was the way the Booster wastegate rod was adusted pre rebuild, ( BTW, this is the engine rebuild kit I orderd from Roodogs through you's ) I agree 10 PSI is not high, but thought during break in I would not push any limits, but feel I am hitting the thermal limits of the EGT's, I assume more boost would cool that down ? Which way would you sudgest I turn the injection Pump to trouble shoot this issue? Should I attempt to increase boost first by adusting rod to wategate? Am I correct that these EGTs are high for 100Kmph on a flat?
 
Joined
Sep 28, 2002
Messages
8,019
Location
Kamloops, BC Canada
 
 
 
 
You just can not just randomly set the timing, you must follow the factory procedure to the letter.

You EGTs are totally out of whack given the conditions you are talking about. You should only see temps like 1200F after pulling long sustained hill with your foot to the floor.

You can expect slightly high EGTs on a fresh engine, but only a little higher.

It is NOT an acceptable practice for your mechanic to just mark the injection pump housing and put it back in the same spot and expect the timing to be on. It would provide a good starting point, but only a starting point and it must be set before putting the engine into service.

The valves should be checked again as well.


~John
 
Joined
Jun 14, 2009
Messages
145
Location
Ottawa, Ontario
 
 
For any one that may have followed this thread, I finally got around to doing the injection timing on this 13BT. This is not an easy task ( getting to the bolts that hold the pump in position is tricky, but doable with some patience ):mad:
The procedure was followed as per Service manual, it turned out that the injection was out by what I can only estimate to be~ 4 deg of retardation ( the match marks from original position on pump housing to block were moved clockwise just shy of ¼” ) This has lowered by ~ 200 to 300 Deg f my EGT’s when under load. :bounce:The engine now has substantially more power. So as John from RADD said, injection timing is critical. I thank him for the advice.
:mad:
 
Joined
Oct 31, 2011
Messages
15
Location
Tasmania,australia
hello , i have also had a rebuild on my 13bt engine , power comes on then seems to drop off when you need it , question : is it possible to glaze up the bore , and lose compression at same time, have set pump timming to the letter , its like something has turned the fuel down , any suggestions please
 
Joined
Mar 11, 2007
Messages
2,308
 
 
Have you checked the basics? fuel, boost, egt, intake restriction ?
 
Joined
Oct 31, 2011
Messages
15
Location
Tasmania,australia
hello hulsty thanks for the info , sorry for taking so long to get back , yes i have checked air intake , fuel , pump rebuild and pump timming set , before the engine rebuild the 13bt when you put your foot down it just flew near put you back into your seat did over 30.000klm before blowing head gasket, and burnning the cylinder linner lip out,, new rebuilt engine , and it is very slugish the torque is not there, temp is all over the place , any suggestions , thank you, regards peter ,,
 
Joined
Jul 22, 2003
Messages
17,901
Location
Perth Western Australia
 
 
 
hello hulsty thanks for the info , sorry for taking so long to get back , yes i have checked air intake , fuel , pump rebuild and pump timming set , before the engine rebuild the 13bt when you put your foot down it just flew near put you back into your seat did over 30.000klm before blowing head gasket, and burnning the cylinder linner lip out,, new rebuilt engine , and it is very slugish the torque is not there, temp is all over the place , any suggestions , thank you, regards peter ,,
It has to be something to do with the fuel.Have you mentioned it to the person that did the pump rebuild?
Have the injectors been checked,normaly you would do them wth a pump rebuild?
Any obnoxious smoke pouring out the back?
 
Joined
Mar 11, 2007
Messages
2,308
 
 
hello hulsty thanks for the info , sorry for taking so long to get back , yes i have checked air intake , fuel , pump rebuild and pump timming set , before the engine rebuild the 13bt when you put your foot down it just flew near put you back into your seat did over 30.000klm before blowing head gasket, and burnning the cylinder linner lip out,, new rebuilt engine , and it is very slugish the torque is not there, temp is all over the place , any suggestions , thank you, regards peter ,,

Cool so what are the figures?

Boost and at what rpm?

EGT's ?

Timming set at ?
 
Joined
Oct 31, 2011
Messages
15
Location
Tasmania,australia
13bt lack of torque

thank you for the reply, new rebuild , new injectors, rebuilt inj pump , checked spill timing set @ 11 deg btdc , checed crankshaft timming turbo boost @15psi @3400rpm . rechecked compression cylinders 460 . 460. 480 .440 . i havetaken my 13bt to 4 different mechanics they say its ok , it starts first go , no smoke no noise , but it is lacking power and torque , goes ok on the straight but does not have that pulling power it use to have , mechanic said turbo boost should not be any higher, there seems to be some question to what boost the ct26 turbo should perform at , put turbo gauge on whilst going up hill and it slowly dropped in psi , it has taken me a year since rebuild to get this far between back and forth to the mechanics , some dont know anything about the jap import 13bt , can any one please help , frustrated, i put it on a dyno tune the reading said only 64kw running very rich top end boost not comming on till the end, just when you need it, thank you for your time. regards peter:bang:
 
Joined
Mar 11, 2007
Messages
2,308
 
 
thank you for the reply, new rebuild , new injectors, rebuilt inj pump , checked spill timing set @ 11 deg btdc , checed crankshaft timming turbo boost @15psi @3400rpm . rechecked compression cylinders 460 . 460. 480 .440 . i havetaken my 13bt to 4 different mechanics they say its ok , it starts first go , no smoke no noise , but it is lacking power and torque , goes ok on the straight but does not have that pulling power it use to have , mechanic said turbo boost should not be any higher, there seems to be some question to what boost the ct26 turbo should perform at , put turbo gauge on whilst going up hill and it slowly dropped in psi , it has taken me a year since rebuild to get this far between back and forth to the mechanics , some dont know anything about the jap import 13bt , can any one please help , frustrated, i put it on a dyno tune the reading said only 64kw running very rich top end boost not comming on till the end, just when you need it, thank you for your time. regards peter:bang:
So what are the EGT's like? 64kw at the wheels isnt too bad, they originally had 89kw at the engine when new at 3400rpm. Though I would probably expect more for that boost level, but if fuel has not been adjusted to suit the extra boost power will be down.

I ran 18psi with my standard CT26. Has it been properly dyno tuned by someone that knows what they are doing and monitors the EGTs? I found when I tuned mine, increasing the max fuel setting and the boost compensator made a massive difference.

I have now a upgraded CT26 from Graeme on here, sees 20psi and about 2000rpm and a maxed out fuel pump to 25psi max boost, goes really well!
 
Joined
Oct 6, 2008
Messages
796
Location
Perth, Australia
Hi Bill, what boost are you getting at 2000rpm? Sounds to mee like the inj pump aneroid control spring is set much tighter than it was prior when it had aged. If you are getting max boost at 3400 and making good power (64kW is about right, great even) I think what is happening is aneroid is not depressing until high in revs, so your torque band will be weird a bit petrol like and undrivable, since you want to be driving 1800-2500 range - 3400 when being silly only when your turbo boost pressure is less throttle (fuel) dependent.

Try changing the aneroid spring pretension. If like the 12HT, there should ba e alarge allen key plug on the top of the anerod, remove it and turn the toothed wheel one full turn clockwise if looking towards the radiator and take for a drive. See if you can get 12psi by 2000rpm - should be easy. Max EGT should be ~ 1270 at 2000rpm (EGT is not a "one temp for all revs" type of thing, 1270F at 2000rpm rising to 1400F at 3500rpm is what I would aim for). So, keep reducing the aneroid tension until the EGT gets to about 1270F at 2000rpm.

Should change it entirely.

*EDIT*

Also, regaind what you mentioned in your other post "IDLE", the "rising boost then falling" at rpm is most likely just the high rpm governer cutting fuel back. It really makes me think that what I said above is exactly the issue, so I wouldnt worry, just try the changes I suggested.
 
Last edited:
Joined
Oct 31, 2011
Messages
15
Location
Tasmania,australia
aneroid control spring

hello , and thank you for the reply and info on my 13bt , to adjust the aneroid spring pretension, i checked out the inj pump and could not find any key plug on top of the inj pump did find a plug on the side of pump undid plug and found a toothed wheel, the manuel said it is a turning guide bushing diagram shows the wheel with a screw driver in the hole showing how to adjust it . is this the one your talkink about ,, do i have to undo anythig else before i turn the wheel one full revolution ,, i went to my diesel injector service centre to run this bye him , he gave me a sturn look and said dont touch , what do you think all this machineary in this shop is for , i then asked him would it hurt any thing if i went ahead and tried it , the look on his face was like i had just insultaded him again , he told me that the engine is running fine and that i had to live with that. if i turn this wheel clock wise its not going to throw the pump out of whack is it ? . again thank you for the reply, it has been a long frustrating problem , iam not a mechanic but shore have had a lesson in diesels, awaiting your reply best regards bill:cheers:
 
Joined
Mar 11, 2007
Messages
2,308
 
 
Sounds like your pump guy is an idiot. I'll respond more in the morning night
 
Joined
Mar 11, 2007
Messages
2,308
 
 
Here is a good thread on fuel adjustments, but you really need a EGT and boost guages and be able to adjust boost to make the most of it.

FYI on my car, I have set the max fuel screw all the way in to the maximum, I have not touched the boost compensator screw and the "guide bushing" has been adjusted pretty aggressivly to give more fuel earlier per boost. This adjustment made a large difference to spool up and low rpm torque. Note I have a 3'' exhaust and dump, small intercooler and upgraded turbo.

Still, without cooler and stock turbo I ran 18psi and adjusted fuel and the car went prettty damn well!

https://forum.ih8mud.com/diesel-tec...-fuel-adjustment-power-increase-answered.html
 
Joined
Oct 31, 2011
Messages
15
Location
Tasmania,australia
hello and thank you for the reply i have adjusted aneroid control spring, i had my 13bt put on a dyno tune and this is the report: complaint is lack of power, and torque,
set vehicle up on dyno with all tunning equipment
checked air fuel ratio boost and exhaust temp, found incorrect boost pressure at low down rpm,
turbo boost not coming into full boost untill high rpm air fuel ratio goes from to rich down low from lack of boost pressure to lean high in rpm when boost pressure comes on, unable to improve tune checked waste gate operation etc, further investigation req , still lack of boost and torque new injectors and pump , engine rebuilt 4000klm ago lstarted to loose torque after turbo manifold gasket blew replaced gasket still no power / torque can you please help , thank you regards bill
 
Joined
Mar 11, 2007
Messages
2,308
 
 
Lean at high rpm? How lean? Have the dyno print outs? I wouldn't think that would be happening.
 
Joined
Oct 4, 2006
Messages
82
Location
Sudbury Ontario
 
 
Hi all
I’ve been having issues with mine to
Pulled the head and had checked... all good
Installed with studs and new gaskets
Compression good. Had injectors checked ok
Also checked exhaust and air intake for restrictions...all good. Nothing measurable
Got new turbo cartridge from kinugawa with upgarded compressor wheel. Should be good for 20-25 psi all day long...best i get is 10 and it drops to 8 as rpms go up. Also have air to water intercooler.
I was checking the timing and noticed its at around 9*
Should be at 11* according to spec. When I increase rpm it’s all over the place between 7 to 9. Never goes over 11. Even when I turn injection pump it hardly moves. At full rpm it should be around 14 to 15 right? I will pull the gear cover and have a look at the advance unit to make sure it is ok.
Any other suggestions?
 
Joined
Mar 23, 2008
Messages
92
Which cartridge do you have? Many of the upgraded arent really an upgrade and mismatched to the engine. Which EGT's do you get? If they are low it's a fuel related problem.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom