1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Is there a way to lube the air pump?

Discussion in '60-Series Wagons' started by sportbiker929, Jul 11, 2005.

  1. sportbiker929

    sportbiker929

    Messages:
    436
    Media:
    3
    Likes Received:
    9
    Joined:
    Jun 1, 2005
    Location:
    Oakley, CA
    Can I lube it internally to prevent premature failure?
     
  2. 60wag

    60wag SILVER Star

    Messages:
    1,926
    Likes Received:
    39
    Joined:
    Jun 25, 2003
    Location:
    Boulder, CO
    You can take it apart and grease the bearings. Be careful not to break the graphite wipers that ride on the vanes.
     
  3. sportbiker929

    sportbiker929

    Messages:
    436
    Media:
    3
    Likes Received:
    9
    Joined:
    Jun 1, 2005
    Location:
    Oakley, CA
    I was thinking of dumping oil into the intake side.
     
  4. Landpimp

    Landpimp GOLD Star

    Messages:
    15,873
    Media:
    1
    Likes Received:
    1,913
    Joined:
    Mar 14, 2003
    Location:
    Gig Harbor WA
    I thought they say "do not oil" on the pump?
     
  5. sportbiker929

    sportbiker929

    Messages:
    436
    Media:
    3
    Likes Received:
    9
    Joined:
    Jun 1, 2005
    Location:
    Oakley, CA
  6. swank60

    swank60

    Messages:
    1,483
    Likes Received:
    231
    Joined:
    Aug 26, 2002
    Location:
    One of Four Presidential Flying Saucers
    That's one of the causes of premature failure. 60s, at times, will release a lot of oil into the breather, where the pump gets it's air. If it pulls that oil into the pump, it'll screw it up.

    You really don't want anything other than air running into that thing.
     
  7. jesterb

    jesterb

    Messages:
    3,058
    Likes Received:
    2
    Joined:
    Jun 11, 2004
    Location:
    Copperhead Rd.

    They do.
     
  8. Landpimp

    Landpimp GOLD Star

    Messages:
    15,873
    Media:
    1
    Likes Received:
    1,913
    Joined:
    Mar 14, 2003
    Location:
    Gig Harbor WA
    funny thing, I read that............but it took me 8 years to read the PS pump cap......that says to used ATF.........no PS fluid ;)