Engine bogs in midrange

Discussion in '40- & 55-Series Tech' started by mattcobb, Nov 4, 2003.

  1. mattcobb

    mattcobb

    Messages:
    109
    Likes Received:
    0
    Joined:
    Jul 30, 2003
    On my 74 FJ40 F2 motor w/ orig carb --as I accelerate the low RPM range is fine, midrange bogs down and engine sputters a bit (sounds carb like) and then as RPMs increase it runs fine. Is this normal for cruisers? If not, what should I check / do?
     
  2. TJDIV

    TJDIV Back in The U.P.

    Messages:
    2,063
    Media:
    9
    Albums:
    1
    Likes Received:
    2
    Joined:
    Jan 28, 2003
    Location:
    Upper Michigan
    Carb, fuel filter maybe? Sounds like a carb possibly, but I don't know the last time you changed filters/etc....
     
  3. 73lndcrsr

    73lndcrsr

    Messages:
    745
    Likes Received:
    4
    Joined:
    May 28, 2002
    I would check the fuel pump and filters. It sounds like fuel delivery to me. How long has it been since you did a tune-up? It could also be worth checking the timing.
     
  4. dogboy

    dogboy

    Messages:
    156
    Likes Received:
    1
    Joined:
    Oct 14, 2002
    here's another 2ยข: check your vacuum lines for leaks, etc... a vacuum/timing advance issue?

    just more pennies on your pile,

    -dogboy- '87 FJ60
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.