Efi,fuses and more

Joined
Sep 29, 2003
Messages
7,702
Location
The Sunshine State
 
 
 
Replaced the efi relay like you guys said too, it still no worky worky...

I also replaced the fusable links. I am still getting no check engine light while i crank the engine. The only light that shows up is the fasten seat belt light. Someone mentioned about switching the wires running to the EFI relay with 10g. wire. that is my next step.....any other ideas would be cool.




A side note, I was wondering about the reverse cut front gears. Does that mean the drive shaft spins in the oppsite postion as well?

thanks again,
-Al
 
Joined
May 1, 2005
Messages
2,229
Location
West Palm Beach, Florida
 
 
 
lowtideride said:
Replaced the efi relay like you guys said too, it still no worky worky...

I also replaced the fusable links. I am still getting no check engine light while i crank the engine. The only light that shows up is the fasten seat belt light. Someone mentioned about switching the wires running to the EFI relay with 10g. wire. that is my next step.....any other ideas would be cool.




A side note, I was wondering about the reverse cut front gears. Does that mean the drive shaft spins in the oppsite postion as well?

thanks again,
-Al
I'm assuming the truck cranks, but no worky worky. See if you are getting spark, if so, introduce some fuel into your intake and see if she'll fire.(spray gas or starting fluid into the intake manifold) If you have spark and she fires, then it's your fuel delivery. If no spark, then you have to solve that problem first. Either way, it may be ECU related due to the PO's dumba$$ mistake. :doh:

Based on your lack of dash lights, I would suspect electtrical problems somewhere. :frown:

This could be anything at this point from a bad ignition switch, ECU, fuel pump distributer etc. You need to find out what you have, then check the other stuff. Best advice I can give you now, don't assume anything.

In answer to your reverse cut gears, the DS turns the same way. The pinion gear is located at the top of the ring gear on the front diff, thus requiring the reverse cut. Otherwise, the front tires would turn the opposite of the rear tires.
 
Joined
Sep 29, 2003
Messages
7,702
Location
The Sunshine State
 
 
 
Capt. Jim thanks for the help, I put in the EFI relay tonight and so no change. It was late (also dark out) so i did not check for spark....I willing to bet there is none. If none I will truck on from there will the electric mumbo jumbo. I never had to mess with electronics on a cruiser or any car for that matter...its um how you say...no fun.

P.S. Jim instead of getting the new fly wheel for the 80 and housing, I orderd a front aussie for Velveeta for the next run at Alpha :)

see ya soon brotha...
 
Joined
May 1, 2005
Messages
2,229
Location
West Palm Beach, Florida
 
 
 
lowtideride said:
P.S. Jim instead of getting the new fly wheel for the 80 and housing, I orderd a front aussie for Velveeta for the next run at Alpha :)

see ya soon brotha...
I'll put my boggers back on for the next run and follow you up knuckle buster. :cheers:

Good luck trouble-shooting the 80.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom