1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

'94 CEL- Code 26

Discussion in '80-Series Tech' started by ajohnson, Jul 25, 2005.

  1. ajohnson

    ajohnson

    Messages:
    23
    Likes Received:
    0
    Joined:
    May 31, 2005
    Location:
    Chandler, AZ
    Just returned from a 3000 mile maiden-voyage in the new-to-me '94 LC. Had not problems in the 1500 mile trip to Memphis, got a nearly rock-solid 15.5mpg on virtually every fill, driving between 70-80mph for virtually the entire 1500 miles. I started the trip with 174k miles on the clock.

    SHortly after we arrived, I noticed a rough idle, especially when the A/C was on. This has been discussed already on another thread.

    After a few days of the rough idle coming and going at random, the CEL came on, and it came and went seemingly at random as well. I knew it to be related to the rough running, so proceeded to drive home the 1500 miles. It remained on most of the trip, though it did go off at times. I noticed mpg dropped to 13.9 when the CEL was on, and went back to 15.5 when it was off.

    I pulled the code yesterday with the paperclip, getting Code 26. THen I cleaned the intake with some carb/intake cleaner, the amt of crud seemed to be fairly minor. Then ran some SeaFoam in through the brake booster line, let it sit before driving around the block. It smoked a decent amount like it should, still have the CEL.

    So, based on my results thus far, I'm thinking perhaps it might be the fuel filter? I'm guessing I ran 200 gallons of fuel through it in a short time, so good chance things were stirred up a bit. Where is the fuel filter located at on this thing? I haven't been able to spot it yet. Is it on the frame rail close to the tank?

    Any other thoughts on what it might be?

    Thanks///
     
  2. landtank

    landtank SILVER Star

    Messages:
    19,197
    Likes Received:
    1,442
    Joined:
    Mar 27, 2003
    Location:
    Groveland MA
    under the intake.
     
  3. ajohnson

    ajohnson

    Messages:
    23
    Likes Received:
    0
    Joined:
    May 31, 2005
    Location:
    Chandler, AZ
    Not sure what you mean??
     
  4. landtoy80

    landtoy80

    Messages:
    5,805
    Likes Received:
    319
    Joined:
    Mar 13, 2003
    Location:
    North Front Range, CO
    I don't have my 80 SFM out with me but is code 26 rich or lean?
    I had 25 and 26 at the same time. I used Toyota FI cleaner and Seafoam and the problem went away.
     
  5. ajohnson

    ajohnson

    Messages:
    23
    Likes Received:
    0
    Joined:
    May 31, 2005
    Location:
    Chandler, AZ
  6. TX_TLC

    TX_TLC

    Messages:
    1,476
    Likes Received:
    8
    Joined:
    Apr 29, 2003
    Location:
    Texas

    Fuel filter is under the hood, not back by the tank. It is on the DS up under neath. Lay under it look up you will spot it.
     
  7. landtoy80

    landtoy80

    Messages:
    5,805
    Likes Received:
    319
    Joined:
    Mar 13, 2003
    Location:
    North Front Range, CO
    I wouldn't think a rich condition would be from a pluged filter. That should cause a lean condition. But I could be wrong.
    It might be a leaking or stuck injector.
     
  8. ajohnson

    ajohnson

    Messages:
    23
    Likes Received:
    0
    Joined:
    May 31, 2005
    Location:
    Chandler, AZ
    Thanks for filter location.

    Kurt- I would tend to agree plugged filter= lean.

    I ran about 3 bottles of Costco Techron through the fuel on the trip, hoping to do an 'extended' cleaning. Based on other previous discussions, I think I may try the Redline fuel additive.
     
  9. parabola

    parabola

    Messages:
    316
    Likes Received:
    0
    Joined:
    Jun 27, 2005
    Location:
    Austin, TX
    And I want to know WHO THE HELL DECIDED TO PUT IT THERE?! :mad:
     
  10. landtoy80

    landtoy80

    Messages:
    5,805
    Likes Received:
    319
    Joined:
    Mar 13, 2003
    Location:
    North Front Range, CO
    Thats one thing I like about the 62, they put the filter on the wheel well and out in the open.