'94 CEL- Code 26

Joined
May 31, 2005
Messages
23
Location
Chandler, AZ
Just returned from a 3000 mile maiden-voyage in the new-to-me '94 LC. Had not problems in the 1500 mile trip to Memphis, got a nearly rock-solid 15.5mpg on virtually every fill, driving between 70-80mph for virtually the entire 1500 miles. I started the trip with 174k miles on the clock.

SHortly after we arrived, I noticed a rough idle, especially when the A/C was on. This has been discussed already on another thread.

After a few days of the rough idle coming and going at random, the CEL came on, and it came and went seemingly at random as well. I knew it to be related to the rough running, so proceeded to drive home the 1500 miles. It remained on most of the trip, though it did go off at times. I noticed mpg dropped to 13.9 when the CEL was on, and went back to 15.5 when it was off.

I pulled the code yesterday with the paperclip, getting Code 26. THen I cleaned the intake with some carb/intake cleaner, the amt of crud seemed to be fairly minor. Then ran some SeaFoam in through the brake booster line, let it sit before driving around the block. It smoked a decent amount like it should, still have the CEL.

So, based on my results thus far, I'm thinking perhaps it might be the fuel filter? I'm guessing I ran 200 gallons of fuel through it in a short time, so good chance things were stirred up a bit. Where is the fuel filter located at on this thing? I haven't been able to spot it yet. Is it on the frame rail close to the tank?

Any other thoughts on what it might be?

Thanks///
 
Joined
Mar 13, 2003
Messages
5,811
Location
North Front Range, CO
I don't have my 80 SFM out with me but is code 26 rich or lean?
I had 25 and 26 at the same time. I used Toyota FI cleaner and Seafoam and the problem went away.
 

TX_TLC

 
Joined
Apr 29, 2003
Messages
1,480
Location
Texas
ajohnson said:
So, based on my results thus far, I'm thinking perhaps it might be the fuel filter? I'm guessing I ran 200 gallons of fuel through it in a short time, so good chance things were stirred up a bit. Where is the fuel filter located at on this thing? I haven't been able to spot it yet. Is it on the frame rail close to the tank?

Any other thoughts on what it might be?

Thanks///

Fuel filter is under the hood, not back by the tank. It is on the DS up under neath. Lay under it look up you will spot it.
 
Joined
Mar 13, 2003
Messages
5,811
Location
North Front Range, CO
I wouldn't think a rich condition would be from a pluged filter. That should cause a lean condition. But I could be wrong.
It might be a leaking or stuck injector.
 
Joined
May 31, 2005
Messages
23
Location
Chandler, AZ
Thanks for filter location.

Kurt- I would tend to agree plugged filter= lean.

I ran about 3 bottles of Costco Techron through the fuel on the trip, hoping to do an 'extended' cleaning. Based on other previous discussions, I think I may try the Redline fuel additive.
 
Joined
Jun 27, 2005
Messages
316
Location
Austin, TX
TX_TLC said:
Fuel filter is under the hood, not back by the tank. It is on the DS up under neath. Lay under it look up you will spot it.
And I want to know WHO THE HELL DECIDED TO PUT IT THERE?! :mad:
 
Top Bottom