Trouble shooting 2F

Discussion in '60-Series Wagons' started by Blue60, Nov 7, 2005.

  1. Blue60

    Blue60

    Messages:
    612
    Likes Received:
    4
    Joined:
    Mar 16, 2003
    Due to rust thru of old tube, I just replaced the EGR cooler to EGR valve tube on my FJ60 (86). Has certainly taken care of the "popping" and backfire I had prior to warming up.

    Now, new problem... won't run well unless fully choked. Before replacement , truck ran very well. Truck starts easily, but just runs rough and seems to be on the verge of stalling unless I keep full choke.

    Suspect vacumn problem?

    I have the emission control repair manual, which I will start trouble shooting with this weekend. In the meanwhile, can someone confirm for me whether or not the high altitude compensation (HAC) valve, always draws air from the bottom tube open to atmospheric (ambient) air under all condtions. It seems to on mine, but the truck does seem to smooth out a bit when I plug that particular port. From the manual it doesn't make sense to me....

    Thanks and cheers

    Dave
     
  2. NocalFJ60

    NocalFJ60

    Messages:
    3,550
    Media:
    6
    Albums:
    1
    Likes Received:
    6
    Joined:
    Aug 2, 2004
    Location:
    San Francisco Bay Area
    The HAC would not cause problems with the cruiser not idling. I would check your fuses..maybe the engine fuse. Also the EGR valve might be stuck open which would cause it not to run good.
     
    Last edited: Nov 7, 2005
  3. brett76

    brett76

    Messages:
    1,264
    Likes Received:
    3
    Joined:
    Aug 17, 2005
    Location:
    t town, wa
    maybe with all that rust damage it was sucking in clean air and the carb was adjusted for that. so maybe now its running to lean since you have to have the choke out. maybe just rich it up some?
     
  4. beaufort-fj60

    beaufort-fj60

    Messages:
    4,511
    Media:
    10
    Albums:
    1
    Likes Received:
    11
    Joined:
    Feb 5, 2005
  5. Blue60

    Blue60

    Messages:
    612
    Likes Received:
    4
    Joined:
    Mar 16, 2003
    Thanks...

    Appreciate all the hints...will post back when resolved!

    Cheers, and Keep on Cruising!

    Dave
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.