Got me a Hundy! (1 Viewer)

greenseaman

SILVER Star
Joined
Apr 24, 2008
Messages
2,567
Location
Conway, SC
I found myself a 1999 Land Cruiser. I had Dbenke check it out for me and we picked up it last night. It seems to be in pretty good shape, so I should be able to get a lot more miles out of it. It needs a new key fob, fender flare and an antenna mast, but other than that it should be good. I may do the timing belt and water pump since I am unsure if it has been done. The guy I bought it from said that it was done at 90k and 180k but he has no record and it didn't specifically say it on car fax... It is silver and has 204,000 miles on it. It will be Becca's daily driver and I may get to drive it every once and a while! LOL! I put 285 KO2s on it this morning and it rides great! I may be putting a DVD receiver in it sometime to upgrade the stock radio. I may also get some Wet Okole seat covers and Floor mats. Other than all those little things and some maintenance, hopefully it will be a good truck for many more miles!
DSCN2732.JPG
DSCN2733.JPG
 

CharlestonG8R

Hey y'all!
SILVER Star
Joined
Aug 11, 2013
Messages
3,559
Location
Charleston, SC
Congratulations, Scott! It looks like a very nice vehicle. So you're an all-Toyota family, eh? The Hundred, Taco, and 4Runner?
 

greenseaman

SILVER Star
Joined
Apr 24, 2008
Messages
2,567
Location
Conway, SC
I ordered a Sony DVD receiver for it and should get it installed Friday. The antenna mast should be here Sat. and I'm hopimg to get the keyless entry working by programming some keys from Ebay. I've got heater hoses and tees ordered from Sparks that should be here by the end of the week. I want an Ultra-gauge MX that I can program to get the auto trans temp. Becca is lucky to have such a great truck! LOL! At least she thinks it's hers!! I've also got a timing belt and water pump for the Tacoma! I can leave my truck out of all the fun. I've got cabin filters for the Hundy too! There were none installed and I've gotta vacuum out all the leaves! I hear it's common for them not even to come with them installed. Got a lot to do!!!
 

CharlestonG8R

Hey y'all!
SILVER Star
Joined
Aug 11, 2013
Messages
3,559
Location
Charleston, SC
I ordered a Sony DVD receiver for it and should get it installed Friday. The antenna mast should be here Sat. and I'm hopimg to get the keyless entry working by programming some keys from Ebay. I've got heater hoses and tees ordered from Sparks that should be here by the end of the week. I want an Ultra-gauge MX that I can program to get the auto trans temp. Becca is lucky to have such a great truck! LOL! At least she thinks it's hers!! I've also got a timing belt and water pump for the Tacoma! I can leave my truck out of all the fun. I've got cabin filters for the Hundy too! There were none installed and I've gotta vacuum out all the leaves! I hear it's common for them not even to come with them installed. Got a lot to do!!!
Yeah, some of the 100's don't even have an option to change out the cabin filter. Mine has that issue - I had to order a different chamber so that I could install the cabin filters (waiting for it to cool down a bit). And of the 100's where there is a door to change them, the factory often left them out anyhow. o_O Do you have a rear locker?
 

tabraha

Hello My Name is: TAD
SILVER Star
Joined
Aug 20, 2003
Messages
2,563
Location
South Carolina
Welcome to Hundy land. Sounds like you found my old cabin air filter thread already. Have you looked for the t-belt change out sticker? Most of the time it's where it is shown in my pic below or very close. Mr. T dealer should have record of it too.
 

greenseaman

SILVER Star
Joined
Apr 24, 2008
Messages
2,567
Location
Conway, SC
I haven't seen a sticker and when I ran the vin on the website it wasn't listed, but I'll get them to run it again at sparks for me!
 

greenseaman

SILVER Star
Joined
Apr 24, 2008
Messages
2,567
Location
Conway, SC
So I couldn't find a timing belt sticker and the only maintenance at the dealership was a front door actuator! Oh well!! On another note, I got the timing belt and water pump PM done on the Tacoma finally, so now I guess it'll be time for the hundy soon!
 

greenseaman

SILVER Star
Joined
Apr 24, 2008
Messages
2,567
Location
Conway, SC
I also got the stereo put in today and it works with the stock amplifier and the subwoofer, and sounds good. Plus I personally was able to fix the broken antenna mast last nite! A piece of cake!!!
 

Users who are viewing this thread

Top Bottom