FJ40 signal flasher - location help?

L

Lor

Joined
Mar 5, 2003
Messages
127
Location
Seattle, WA
I need to fix my dead signal. Could someone point to where I can find this unit? It's a '78. Thanks.
 
bj42turbo

bj42turbo

Joined
Sep 7, 2002
Messages
368
Location
Victoria, Australia
Lor
I have just replaced mine it was located just above the brake pedal..................Dazz

P.S I did already answer your ? on the tread "40 series flasher faulty" good luck :)
 
L

Lor

Joined
Mar 5, 2003
Messages
127
Location
Seattle, WA
Thanks for answering. I did get your other post. Just that you said you had a BJ instead and you're on the right hand side. Mine is left hand drive, and I check above the brake pedal, but didn't see it.
 
bj42turbo

bj42turbo

Joined
Sep 7, 2002
Messages
368
Location
Victoria, Australia
[quote author=Lor link=board=1;threadid=3720;start=0#msg27395 date=1058422101]
Thanks for answering. I did get your other post. Just that you said you had a BJ instead and you're on the right hand side. Mine is left hand drive, and I check above the brake pedal, but didn't see it.
[/quote]

Any luck finding it I just thought of one way. Put on your hazzards i think you said they are still working. Then you should be able to hear the clicking sound produce my the flasher can .........Dazz
 
L

Lor

Joined
Mar 5, 2003
Messages
127
Location
Seattle, WA
I think I might have found it. Does it has a stamp with "turn signal" on there? I found this unit bolt to a bracket above the clutch pedal, near the fuse box. It has two wires (green with strips) with a T shape that plug into the unit. Is this the flasher? Is there aftermarket? I've heard someone got this unit at NAPA for around $2. Anyone happen to know their part #?
 
L

Lor

Joined
Mar 5, 2003
Messages
127
Location
Seattle, WA
Thank you for all your help. The signal is now working.
 
bj42turbo

bj42turbo

Joined
Sep 7, 2002
Messages
368
Location
Victoria, Australia
[quote author=Lor link=board=1;threadid=3720;start=0#msg27809 date=1058591791]
Thank you for all your help. The signal is now working.
[/quote]


What was the end result........Dazz
 

Users who are viewing this thread

Top Bottom