AC, A/C, Air Conditioning Symptoms (1 Viewer)

Joined
Feb 4, 2020
Messages
173
Location
San Marcos, TX
I am having some issues with my 2000 LC air conditioning and can't seem to find the right search terms that produce a thread with my symptoms, thus the thread title for the future.

Recently on long road trips 6+ hours, after a few hours or so my AC will stop blowing cold. it worked fine and good cold air until the long sustained high speeds.

Now, yesterday I got in to run an errand and it is in the 80s here and the A/C would blow but not get COLD. It was cooler than the outside temp but never got to that really cold temperature while on. Has anyone got any ideas for me to check? I know AC work requires specific knowledge and understanding and this would be my first time dealing with any AC issues so I'm not opposed to taking it to the dealership if it is obviously beyond my Saturday driveway repair ability.

Thanks!
 
Joined
May 20, 2019
Messages
1,268
Location
Lost Wages
Your fan blower is working, which is a good sign. Next to check is your refrigerant low pressure reading. You can get a gauge from your local auto store which most of the time comes with the refrigerant can. Top up and try again.
 
Joined
Feb 4, 2020
Messages
173
Location
San Marcos, TX
currently going through the same issue and it turned out to be the HVAC blend door actuator
Yeah the guy at the auto store said it could be that when he listed to my explanation.
I got one of those ac recharge cans and did it today and it seems to be blowing good and COLD now. I’ll check again this week to see if the pressure goes down and then figure out where I have a leak if it didn’t keep pressure.

But for the blowing warm after a few hours of highway driving the actuator door could be the culprit.
 

Users who are viewing this thread

Top Bottom