Wet OEM tool bag... I think I found out why.

Joined
Sep 17, 2003
Messages
589
Location
Edmond, OK
Okay, after looking at what could be leaking water into my rear quarter, I noticed that the seal around my rear sliding side windows is "separating". I could see on the inside where the wind had forced water around the glass and inside to run down into the quarter. I have attached a couple of pics I took this evening :D

C-Dan, how do I go about fixing this one??? ???

Jody.
 
Joined
Sep 17, 2003
Messages
589
Location
Edmond, OK
And a close-up...
 

cruiserdan

SupportingVendor Emeritus
Moderator
Joined
Mar 27, 2003
Messages
25,267
Location
Land Cruiser Heritage Museum broom closet
Jody,

I have seen that "gap" before. I have it on one of my quarter windows. The only way to fix it is to replace the "run" around the window frame. I'm not sure that your water issues are coming from that gap. You would need to force water thru that gap to get it inside the vehicle. I still think that you are getting water thru the holes in the quarter panel where the belt moulding is attached. Do this:

Remove the LH interior access panel and study the inside surface of the quarter panel. look for "tracks" of water that may be running down the panel. In addition, flood the glass area with a garden hose while you watch the inside of the quarter.
One other possibility is that the vent to the rear of the glass is leaking.

D-
 
Joined
Sep 17, 2003
Messages
589
Location
Edmond, OK
Hmmmmm.... I'll dig a bit deeper into C-Dan's suggestions.

Jody.
 
Joined
Mar 27, 2003
Messages
12,519
Location
Somewhere in the foothills...
Mine has the same gap on the DS. Haven't checked the PS... might be there too.
-B-
 

Users who are viewing this thread

Top Bottom