weird code...passenger side oxy. sensor (1 Viewer)

Joined
Aug 25, 2010
Messages
56
Location
Whidbey Island, WA
This is strange. About 5 months ago my check engine light came on and the code was 21, oxygen sensor or sensor heater. Didn't come back on for awhile, maybe 3 weeks later. Then about a month ago it came on again, same code. then nothing for a couple days. Then it started coming on every other day or so and I realized it was showing up on the same road at the same spot. Almost every time I drove by (only heading home never away from home). So anyway I bought two new sensors since the old ones are the originals with 250K on them. Never got around to installing the sensors and never saw the light again and it has been over a month. Strange!

I guess I will put the new sensors on anyway.
 
Joined
Aug 25, 2010
Messages
56
Location
Whidbey Island, WA
I did stop one day to see what the heck was around there. There is a house back in the woods. Maybe its a grow house and one of their digital ballast is setting it off :) Someone told me that they emit a signal that the police can use to track them down!

Just an FYI on the sensors. There is a guy on Ebay that has been selling new Toyota sensors with opening bid of 29 bucks. The first one I picked up for 29.50 and the second one for 34 bucks. Just do a search for the toyota part number 89465-69015. He must have bought out a dealer's stock or something because he has been selling them for awhile.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom