Power to AC Amplifier? (1 Viewer)

Joined
Jul 13, 2015
Messages
396
Location
Samish Island, WA
Hi All,
I am trying to sort out my AC electrical on my 62 with LS swap (PO by passed the amplifier). Currently wired directly to the AC switch, bypassing the pressure switch and thermoresistor. I see the power wire (Black white) to the AC amplifier, but it is not energized when running (not unexpected). The wiring diagram looks like it goes directly to the ignition switch, but I can't tell. Can anyone tell me if there is a connector somewhere that may be unplugged or where I should be looking? Hoping someone has dug in there and can tell me where to look. Thanks
 

John Staton

SILVER Star
Joined
Oct 23, 2017
Messages
877
Location
The Woodlands, TX
mine is bypassed because it kept burning out amplifiers. As you probably know you just have to manually cycle the compresser on and off to avoid it freezing. I have a temp guage in my vent and when it reaches freezing I cycle it off for a bit. I have a weber carb so really only needed it for the cycling, not idle control. I have seen another solution with a gadget that has a temp prob and you set the upper and lower limit but it just has not made the list. Anyway.....if you decide to go a different route rather than the stock amplifier there is info on Mud with a solution.
 

tmxmotorsports

SILVER Star
Joined
Jul 3, 2016
Messages
2,174
Location
OBX Nc
Hi All,
I am trying to sort out my AC electrical on my 62 with LS swap (PO by passed the amplifier). Currently wired directly to the AC switch, bypassing the pressure switch and thermoresistor. I see the power wire (Black white) to the AC amplifier, but it is not energized when running (not unexpected). The wiring diagram looks like it goes directly to the ignition switch, but I can't tell. Can anyone tell me if there is a connector somewhere that may be unplugged or where I should be looking? Hoping someone has dug in there and can tell me where to look. Thanks
Have you tried reseting the circuit breaker in the fuse box then check for power to the amplifier?
 

tmxmotorsports

SILVER Star
Joined
Jul 3, 2016
Messages
2,174
Location
OBX Nc
mine is bypassed because it kept burning out amplifiers. As you probably know you just have to manually cycle the compresser on and off to avoid it freezing. I have a temp guage in my vent and when it reaches freezing I cycle it off for a bit. I have a weber carb so really only needed it for the cycling, not idle control. I have seen another solution with a gadget that has a temp prob and you set the upper and lower limit but it just has not made the list. Anyway.....if you decide to go a different route rather than the stock amplifier there is info on Mud with a solution.
Ive added an ac idle up sylenoid to a weber carb
 

Users who are viewing this thread

Top Bottom