Need help on '73 FJ40 Carb Linkage

  • Thread starter Ground Up
  • Start date
  • Watchers 0
Ground Up

Ground Up

Joined
Feb 1, 2002
Messages
417
Location
PNW
Can someone post or send me some pics showing the hookup of the accelerator linkage and cable? I have a 10/72 FJ40 with stock F engine. I am trying to setup the carb back to stock setup. I have all of the parts but, the accelerator cable bracket (SOR part #042-66) seems to interfere with the hose that comes out of the lower part of the carb.

Any help would be appreciated.

BTW this transition year (9/72-3/73) thing sucks! :mad:

Thanks,


Sniper
 
toddslater

toddslater

Joined
Oct 31, 2002
Messages
1,501
Location
Kennett Square
Sniper,

Mine is the same production date...late 72. I'll take some digitals tonight when I get home and postem. As I recall it is a tight squeeze for the lower center vacuum hose at the base of the carb.

Todd
 
Ground Up

Ground Up

Joined
Feb 1, 2002
Messages
417
Location
PNW
Todd-

Thanks for the pics. Ok I lied I have a accelerator bracket (SOR #42-66) that i got from SOR is wrong or at least different than yours. I'll give them a call and see if they have the right one.


Thanks that helped a bunch!


Marc
 
toddslater

toddslater

Joined
Oct 31, 2002
Messages
1,501
Location
Kennett Square
I looked at my 2002 SOR catalogue, the 9/72-9/73 bracket on page 042 as number 66 looks to be the right animal. Maybe they just sent you the wrong one. Was it new or used ? If you need better shots let me know and I'll unbolt it for a better look. &nbsp:Do you have the rod assembly ?
 

Similar threads

Users who are viewing this thread

Top Bottom