Need help bad!@!

Joined
Oct 6, 2004
Messages
52
Location
ONTARIO CALI
I came across a recent problem with my 92 cruiser. I notice when my engine light comes on that the vehicle will not start. This just starting happening a few weeks ago. When this happens i have to get it jumpstarted. when someone jumps it, it will start up automatically. the engine light will go off and stay off for a couple of days. but once it turns back on, it will only let me start the vehicle once or twice then it will not let me start it again. when i try to start it again, it will only make the "clicking noise" as if it is coming from the starter. i know its not the battery cuz i have swapped it out with a new one and it still does the same thing. i have also changed the distributor, ignitor, plugs, and wires. if you have any solutions please let me know.

also one more thing.. i recently did an oil change at home. i noticed that once i started up the cruizer, after the oil change, that i had a rough idle. (kinda like an air flow sensor problem) the idle fluctuates moderatly up and down and somtimes acts as though it wants to shut off after it declines to a certain rpm.
any answers.???

by the way it is a 92 landcruizer, 196,000 miles.

thanks for you input
 

IdahoDoug

 
 
Joined
Aug 9, 2003
Messages
8,958
Sounds like you need new starter contacts to me. Call Cdan immediately and get them in before your starter is burned. These are different from the 93 up contacts, I believe. Best way is to have the serial number off the starter for Dan.

As for the idle, check the large rubber tube connecting the air cleaner to the engine. The bellows section will likely have cracks on the bottom from reefing on it to pull the air cleaner lid off instead of properly removing the tube first. Bet you also checked your air cleaner during the oil change, eh???


DougM
 

landtank

SILVER Star
 
 
Joined
Mar 27, 2003
Messages
19,670
Location
Groveland MA
Yup starter contacts. As for the rough idle it's most likely do to with the starter sticky in the on position and dragging down the engine. DON'T drive the truck until this work is done.
 
Joined
Oct 6, 2004
Messages
52
Location
ONTARIO CALI
yes i did change the oil and filter at the same time... lol... i need to get this number for cdan so i can take care of this sitution as soon as possible. and snowwolfwarrior, i wasnt able to find your post in regards to the freet set you were talking about.
 
Top Bottom