climate control unit is not working... (1 Viewer)

Joined
Sep 22, 2010
Messages
492
Location
...where the redwoods meet the ocean...
on our 97 lc. I tried to adjust the air flow with just the vent on but nothing happened when I pushed the buttons. Then I tried the ac and still nothing.

Nothing happens whenever I push any of the buttons on the climate control unit...is there a fuse that might be out or is it something mechanical?

thnx,
t
 
Joined
May 31, 2010
Messages
153
Location
Southern California
on our 97 lc. I tried to adjust the air flow with just the vent on but nothing happened when I pushed the buttons. Then I tried the ac and still nothing.

Nothing happens whenever I push any of the buttons on the climate control unit...is there a fuse that might be out or is it something mechanical?


Are you referring to the fan speed (could be your blower motor resistor), or the temperature mode (heat cold door stuck or the engine heater valve mechanism, can't remember the exact name of it right now sorry)?
 

justbecause

perpetually lost.
Joined
Jun 9, 2008
Messages
3,555
Location
al
 
 
on our 97 lc. I tried to adjust the air flow with just the vent on but nothing happened when I pushed the buttons. Then I tried the ac and still nothing.

Nothing happens whenever I push any of the buttons on the climate control unit...is there a fuse that might be out or is it something mechanical?


Are you referring to the fan speed (could be your blower motor resistor), or the temperature mode (heat cold door stuck or the engine heater valve mechanism, can't remember the exact name of it right now sorry)?
since his problem is fixed ill hijack the tread if at all possible.

I can not choose between hot and cold I can not seem to get the right set of search words to find what I need to do.
When I slide my temp control toward cold I hear a clicking under the dash. Slide to heat, clicking stops. So I know the clicking is from the controller trying to change between hot and cold but it is stuck on heat.

How do I start trouble shooting this??
 
Joined
Sep 6, 2003
Messages
3,185
Location
Tulsa, OK
 
if it's the auto climat control, it's probably the control box under the dash above your right foot. Mine worked on and off and on and off for ever. Dealer had the truck for 3 weeks couldn't figure out the issue.
 
Joined
Jun 14, 2009
Messages
783
I'm dealing with the same issue with my LX 450 which is auto climate. I have tons of electrical issues though. Where could I find a replacement box that is under the dash (besides through the stealership)? And also, is there something cheaper to check? I have checked the valve against the firewall, and it's not that I do not? Where is the blower motor resistor?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom