AHC troubles (1 Viewer)

Joined
Jan 12, 2013
Messages
26
Location
Northern europe
 
On my 2005 HDJ100 with ahc the ride is very stiff and the off indicator in the dash is blinking.
TEMS knob has no effect and the height cant be changed.

The codes I get from Techstream are:
c1732
c1763
c1764

The pressure readings are all 0. Height sensors seems to work.
My techstream laptop has about 6 minutes of battery power, but I will pull a screen shot when possible.
The measured diff in height between front right and left are 9mm when standing flat.

What would the cause of this be? I am leaning towards bad connector, harness or ecu.

Where should I start looking?
 
Joined
Jun 4, 2016
Messages
1,436
Location
Gump in the 406
Bad harness, control valve solenoid, or accumulator solenoid are the common problem areas C1732 and C1763/C1764. You're gonna need to check terminals with a meter to determine which is the culprit. Will send you a PM for a few things to check.

Believe it defaults to sport in this circumstance, so you're feeling the stiff ride due to that.
 
Joined
Sep 27, 2007
Messages
1,760
Location
Charlotte NC or ACT area Australia
 
 
With two leveling valve faults and a height accumulator fault I'd focus initial fault finding on the main control valve and height accumulator solenoid connectors and cabling. There is a common wire (blue/yellow) between the two solenoid assemblies that would take down both. So I'd initially check the integrity of this area, you'll need the AHC EWD to go further but if you're subject to underbody corrosion, road slush etc I think you'll find your problem here. To aid in fault finding you can attempt to clear DTCs and with IG on go into the AHC signal check functions within Techstream and cycle the leveling valve and height accumulator solenoids - they will click and their status will change on the screen when you get them working.
 
Last edited:
Joined
Jan 12, 2013
Messages
26
Location
Northern europe
 
Thanks for the tip!
We do get quite bad winters with salted roads here, so I will start with the wireing between the solenoid assemblies.
 
Joined
Jan 12, 2013
Messages
26
Location
Northern europe
 
I have just performed the test in techstream.
They all failed. I heard a relay click only to be followed by an error in techstream s307-82.
Once or twice the motor relay actually worked, but it was far from flawless operation.

Did not have the possibility for further investigations. I hope the weekend will bring some LC quality time.
 
Joined
Jan 12, 2013
Messages
26
Location
Northern europe
 
I found this:
meow
A google translation makes it more understandable, but its still not clear to me if he has rerouted the harness.

Has anyone else performed this operation?

Edit:

Went out and had a look. The 6th picture is from the rearmost left corner.
It looks like a quite harsh place for placing connectors.
I will clean the connectors and see if they are corroded and hope for the best.
 
Last edited:
Joined
Sep 27, 2007
Messages
1,760
Location
Charlotte NC or ACT area Australia
 
 
Have you isolated the problem down to a section of the harness or a connector? There's quite a bit of slack in the existing harness that will allow an in situ repair if needed. I've found that whilst the protective shrouds over connectors are good at keeping abrasive dirt and crud out they are also good at keeping it in, eventually chaffing through insulation. And throwing salt slush in the mix certainly doesn't help. I'd disconnect both the height solenoid and main valve block solenoid and see if one or the other will actuate - i.e. see if isolating them lifts the common fault. Try cleaning connectors and peeling back insulation for inspection, do continuity checks section by section. Refer back to the EWD as necessary, but the underbody harness for these solenoids is pretty easy to follow. As I mentioned earlier there is one wire (the blue/yellow off pin 2 on the control valve and pin 1 on the height accumulator solenoid) that is spliced together and provides common return back to pin 24 on the ECU, if that wire was open/shorted it would explain a lot.
 
Joined
Jan 12, 2013
Messages
26
Location
Northern europe
 
I will do the check the solenoids and then see whats inside the connectors.
I will have my eyes open for the blue and yellow cable.

Thanks!
 
Joined
Jan 12, 2013
Messages
26
Location
Northern europe
 
I could only check the control valve solenoid.
I tried removing the accumulator connector, but the truck has been antirust treated with an bitumen compound.
The person who put the bitumen on must have thought that the connectors also could rust or at least that grey is a ugly color comparing to black.
Neither the accumulator connector nor the connector in the rear most corner was possible to pull apart without risking destroying something.
Routing a new harness sounds more and more compelling. It is only 6 leads.

Another observation I made is than the off indicator takes longer to light up if the weather is dry. In wet or moist conditions it comes instantly.
 
Joined
Jan 12, 2013
Messages
26
Location
Northern europe
 
One other thing that confuses me is the "+B Power Source Voltage"
Its fluctuating and rarley over 9 volts, even with engine running. The IG power seems more ok with 12.7 volts.

Is this somehow related to my problems?
 
Joined
Sep 27, 2007
Messages
1,760
Location
Charlotte NC or ACT area Australia
 
 
The voltage at B should be between 9-14, but it's a straight shot through the main relay off the AHC-B fuse and the battery bus. I would expect it should align very closely with what you're reading at IG. Wouldn't hurt to pull and check the resistance of the main relay contacts (it's the can relay mounted next to the AHC ECU) measure the voltage at pin 2 and it might be worth replacing the AHC-B 15A fuse with a spare, regardless if the fitted one looks/checks ok. It's not unheard of for fuses to look/check ok but behave intermittently under load. Low voltages and voltages that fluctuate on the design thresholds can cause lots of vague issues with ECUs. I'd also check the ECUs grounds off pins 7 and 26 (white/black) are good while you've got your head under the dash. I'm still thinking the wire off SLB (S9- 24) which provides + to both solenoids needs to be ruled in or out.
 
Joined
Jan 12, 2013
Messages
26
Location
Northern europe
 
I measure the relay and the red/white is 12.5.
Blue/white is 12.5 only when key is turned to ignition. After that it decreases to about zero.

Can I try a normal cube relay instead of the beer shaped one?

IMG_20160625_220244.jpg
 
Joined
Jan 12, 2013
Messages
26
Location
Northern europe
 
The relay tests ok.
I can hear the relay click both closing and then open again when the off indicator starts flashing in the dash.


After relay opens again, I have 0.18volts on pin 1 and 3
 
Last edited:
Joined
Jan 12, 2013
Messages
26
Location
Northern europe
 
It is hard to find someone that knows something about the AHC-system.
I left the truck at a small shop that works with car electrics.
I told them my findings and gave them the wiring diagrams and said that I suspected a faulty wire.
One a half day later I pick up the truck. They haven't made any real progress, but says that they can't clear the codes in the ahc-ecu. They claim that they have found a wire and fixed it, but it hasn't fixed the ahc.
Since I have Techstream, it shouldn't be any problem for me to clear the codes, it has worked before.
Wrong. Now I also cant access the fault codes in the AHC. Data list works. Other ecu's like abs, engine and vgrs works too, but not fault code reading in the ahc-module. The truck is lower and stiffer than before too.

Quite dull about this I had some time over for checking the truck. So I decided to measure the Fluid pressure sensor at the pump.
It is a bit different than the one in the manual, but I put 4,5 volts between the two lower posts and measure the volts between the top and the lower right posts. The reading I see is 3,35 volts. The manual says around 4,5 volts, but the sensor has changed and maybe also the output.
Does anyone know what the reading should be?

I have suspicions that the shop fried the ahc-ecu. If I should try to find a replacement, which years will fit?
Or can it be the wire that they claimed to have fixed interferes?
 
Joined
Jan 12, 2013
Messages
26
Location
Northern europe
 
Yes, I disconnected the batteries. The HDJ100 has dual batteries in parallel.
The only result from this was that the vgrs got confused. It was an awkward feeling driving with the steering wheel 180 degrees wrong and feeling it slowly adjust to the correct position while driving. First I thought I was getting crazy when I slowly had to turn the wheel even though I was driving straight on a straight road, but eventually it found the correct position.
 
Joined
Sep 27, 2007
Messages
1,760
Location
Charlotte NC or ACT area Australia
 
 
Try manually reading then clearing any AHC codes then I'd re focus fault finding effort back in the area of the two original faults and establish once and for all the integrity of the cabling and connectors to the height and main solenoid valves.
 
Joined
Jan 12, 2013
Messages
26
Location
Northern europe
 
I did the manual readouts and got:
18, 31, 32, 33, 34, 36, 63 and 64.
After clearing the dtc's only 32 remains and I can now see that code in Techstream too. Thank you PADDO!

ALL the active tests still fails in Techstream.
The trucks rear height sensor says -76mm and front wheels are -9mm vs -36mm. Very stiff ride. Concrete roads are not fun even with 16" inch rims.
I will try the manual test, but I don't have much hope for it. I would really like to raise at least the rear end a bit.

Edit:
Active test with shorting of ts and e1 also failed.
 
Last edited:
Joined
Sep 27, 2007
Messages
1,760
Location
Charlotte NC or ACT area Australia
 
 
Manually clearing AHC DTCs usually unlocks the ecu when it won't communicate with Techstream, so it's good that you've seemingly got the problem back to the front leveling valve solenoid/cct. To me the way forward is to disconnect the main solenoid valve connector and check the solenoids continuity/resistance using the FSM pin out as a guide, should be around 3 ohms I believe - I'll confirm that if you need. If they are ok you'll need to disconnect the harness from the ecu and check the harness continuity.
 
Last edited:
Joined
Jan 12, 2013
Messages
26
Location
Northern europe
 
I redid the solenoid test and got 3.8 ohms on all 4 of them, so I guess that I am down to a wire.
If I read the ewd correctly then it is the black-yellow wire.
What I cant read out is in which connector in the rear corner the harness goes.
Also since the under body is covered in a substance, that can only be described as tarlike gum, really makes it hard to see the colors of the wires.
With gravel in my eyes I tried to follow the harness on the frame, but it disappears around the rear axle, so no luck there.

One more question that confuses me: If only dtc 32 is shown, which indicates that the front leveling valve is affected, why doesn't the height control of the rear axle work?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom