78 horn switch wire problem

Joined
Sep 4, 2021
Messages
22
Location
riyadh
I’m checking all the switches before I start connecting the wire harness, and the horn switch is giving me an issue. I’ve looked at coolermans wiring diagram, still can’t figure it out.

Green/rd in seems correct, but the white out doesn’t get continuity, nor does it even appear to be a part of the horn circuit. It looks more like a part of the high beam switch (see pictures)

Every section has been cleaned and checked individually, and I have continuity from the green wire all the way through through the contact ring and each button to the center of the wheel.

But there it ends. When traced, the white wire that is paired in the same plug is soldered to the high beam function switch, and actuates on the momentary movement of the switch. Nothing seems to come close to contacting the column.

I know the power comes from the horns, to the switch, with path to ground to complete the circuit.

The six point plug works as expected, ground centers, left and right on one side, high and low on the other.

Is the ground supposed to be in the column itself, and the white is a ground for the momentary high beams?

I can’t really check the old harness, it looked like the plot line of a fast and furious movie, which is why I’m replacing it.
AA1D97F7-0DB9-45AE-B5E3-61B6D70B4BE7.jpeg
D618568A-F2C0-4088-BD35-E1F3C5445E59.png
F8B626EE-8A79-4D01-A89C-737EA8FD1D48.jpeg
 
Joined
Sep 4, 2021
Messages
22
Location
riyadh
And I almost immediately found my answer. I have a bj series switch in my fj.

Also a correction, centers are source, not ground.

Oh well, live and learn😄
 

Users who are viewing this thread

Top Bottom