Temperature Control Not Working

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, Skimlinks, and others.

Nov 16, 2013
1998 100 Series
Manual knobs rear heat no AC

The temperature knob does not change the temperature from the vents. I hear the servo motor whirring when I change the location of the air and the fan blower works just fine. I took a picture of the piece that I think is not working and actually does not move.

Problem solving items checked:
1. Fuses all checked visually and tested as functioning correctly.
2. T-stat changed 50 miles ago. Installed correctly and functioning correctly. Coolant temperature gauge works correctly and no fluctuations or problems. Coolant flush at this time. Toyota Red.
3. Went under the passenger floor board and checked for loose connections or frayed wires with negative results.
4. Did an AC diagnostic check. Outside temp and rear defrost blinking which from my research shows no issues.
5. Took out the center control unit with the knobs. Took it all apart to check for any loose wires or apparent issues. Everything looks fine. I have read about the nuts coming loose and the units inside spinning and the wires getting disconnected. No issues here.

Yesterday when I was sitting in a parking lot fiddling with the knob (temperature knob that is), suddenly it started working. I heard the servo motor from the passenger floor board whir and suddenly the air got really hot. I turned the temperature knob to cool and it worked correctly. 2 minutes later, it no longer worked.

Thanks in advance for any help. I tried to include as much information as I could and do as much on my own. I have researched this for a week now and no luck. Once I get this sorted, the truck will be great. Being CT and December, the :princess: and kids can't go in it without heat.

Thanks all. :flipoff2:
Here is the heat regulator part that doesn't seem to be working to regulate the temperature.


Is that piece I took a picture of the servo?

Anyone know the part number for it?

Any tests to be conclusive on it?
Ok so no real help so far. Let me ask this...

If I wanted to get a new servo for the temp portion, anyone know what the name of it is for a car-parts search?

Had this exact situation happen to me not long ago. I could control what vents the air came out of but it would not blow hot air. It was the fact that I COULD hear the servo that helped me conclude what was wrong - a servo that had gone bad. Turns out it blew with the "cold air" side open blocking off any warm air from coming into the cab. Had it replaced and it works great now!
Well that's great to hear.

My issue is a bit different. I don't hear the servo 99% of the time. I am thinking it's an issue with the controller unit. Might go that route first.

I heard the servo work that once which makes me think it can work.
Yeah for about 5 minutes I got blasting hot heat. At that point I could hear the temperature control servo working. When I made small adjustments, the motor would whir.
You might be able to bench test the servo if you get it out. There is possibly a diagnostic procedure in the FSM. You can go to TIS, Toyota website and get two day access to the FSM for $15. If the AC multifunction display or amplifier has gone bad, that's pretty pricey to fix. I'd want to make sure I'm replacing the right part.

Normally when the servos go bad they make a binding/ clicking noise. I haven't heard of a controller going bad, but it's entirely possible.
Yeah I looked at the servo when it was functioning correctly and it looked and ran as it should.

That leads me to believe it is not a servo problem but more likely that unit that is sending the signal there. Maybe a rheostat in there?

I got a new ac/heat control unit from a local junkyard. I was pretty sure it was an issue with the control unit and not the servo as I was able to get the servo working once for a short time and I didn't get the typical grinding noise of the servo trying to open and close but bad gears.

So here is the unit that I pulled out of the car that was not working.


From my research it has the older assembly in it as evident from the part number here.


Here is the new one.


Newer model number


So if some of you have issues like mine, look into this as a possible solution. I am glad I didn't rip into the dash to get to the servo.

Last question. As you can see from the pictures from the front, the unit I took out has the blower speed button for the rear and the new (junkyard one) does not. I have not opened up the unit yet, but does anyone know if all the buttons will be on the board and it's just a matter of moving the switch to the new unit?

Thanks for the support and suggestions. I have a new servo coming my way because I wanted to have my bases covered. If anyone needs it, let me know.
Yeah I was pretty psyched. I actually found three junked ones within 100 miles from me.

Unfortunately they are places that won't let you onto their lots.

And now for what I paid...$72.50.

Users who are viewing this thread

Top Bottom