Second time failing smog.. Couple questions. (1 Viewer)

Joined
Dec 12, 2020
Messages
3
Location
CA
Bought a '92 from a friend and he said it should have no problem passing smog but of course it's not.

I'm failing at idle.

HC(PPM): max is 120.. I'm at 123
CO%: max is 1.0.. I'm at 1.14

Also no vacuum at EGR so I failed that. Does that have much to do with emissions being high?

Shop suggested a new Cat. Is that over the top? I can weld so its not the biggest deal except they are still expensive and its seeming hard to find a legit OEM one. What do you guys think? Should I do that and if so any suggestions on where to find one?

After it failed the first time I replaced plugs and air filter. Both of those things seemed way overdue. It dropped the CO% by about .2 but need to get it down more. I should've done the wires and Distributor too but didn't. I'll do that but I'm not sure it'll do enough to pass.

Any feedback is super appreciated.
 
Joined
Dec 12, 2020
Messages
3
Location
CA
This might help
Thank you. Lots of info there.
 
Joined
Nov 9, 2012
Messages
10,719
Location
Olathe, KS, USA
Also add a couple bottles of Heet to the gas tank, drive it around for a solid 30 minutes to get it good and warmed up, then get in there and get it done while still good and warm. Hopefully not a big line.
 
Joined
Feb 28, 2012
Messages
978
Location
N. Phx
Also consider changing oil and new filter. If its burning any amount of oil, dirty oil won't burn cleanly and will inflate emissions numbers. Learned this from a lifetime of driving rotary engine Rx7s that inject oil into the intake path to lube apex seals. Clean oil might pull you across the finish line. Good luck,
 

Users who are viewing this thread

Top Bottom