OME install help

Joined
Jul 27, 2005
Messages
1,704
Location
Roseville, CA
Stupid question... I'm in the process of installing the lift. Does the rubber inside the spring perches stay or go?

TIA
 
Joined
Jan 26, 2008
Messages
582
Location
central virginia
Stupid question... I'm in the process of installing the lift. Does the rubber inside the spring perches stay or go?

TIA

depends. hopefully you got enough ome bushings to replace your old worn out ones. if not then you are going to have to leave them if you want to install now.

you should have gotten 24 bushing halves; 4 per spring and 2 per hanger for each side rf, lf, rr, lr.

the old ones are a PITA to get out. if you don't have enough bushings i would wait until you can replace them before proceeding.
 
Last edited:
Joined
Jul 27, 2005
Messages
1,704
Location
Roseville, CA
No, the bushings aren't the prob. Where the spring attaches to the axle, there was some rubber in there, does that stay. So the rubber would be between the the top of the spring and the axle.
 
Joined
Jan 26, 2008
Messages
582
Location
central virginia
No, the bushings aren't the prob. Where the spring attaches to the axle, there was some rubber in there, does that stay. So the rubber would be between the the top of the spring and the axle.

damn if i could read it would help. you are talking about the rubber pad. i left mine in and all is well. if you look they are designed to fit exactly around the perch and in the center hole. looked like they are supposed to be there and if they worked for 25 years the next 25 should also be fine.
 
Joined
Oct 30, 2006
Messages
1,544
Location
Heber City, UT
I did not put mine back in. No problems here. I do remember reading somewhere that it is better to leave them out. You need to get center pin spacers though.
 

Users who are viewing this thread

Top Bottom