New Member Problem Egr (1 Viewer)

Joined
Feb 7, 2006
Messages
1
:confused: Hey fellow LCers,

I have a 1994 Landcruiser that is throwing and engine code . After Diagonsis they have told me its the sensors incorperated with the EGR valve. The EGR is not carboned up so they belive it is the sensors they want huge bucks any ideas on where to begin THANKS
 

e9999

Gotta get outta here...
Moderator
Joined
Sep 20, 2003
Messages
17,406
Location
US
welcome!
will move ya to the 80 section where you'll find plenty of help.
 
Joined
Aug 8, 2003
Messages
9,023
Miles? Any other info, like engine running rough/smooth/normal? An entire EGR valve is under $150, so not sure what huge bucks looks like?

Also, you can get the codes yourself with a factory service manual and a paper clip.

DougM
 
Joined
Apr 11, 2003
Messages
377
Check the codes. Just replaced my vacuum modulator and VSV, cleared right up. Alos replaced ALL the vacuum hose and cleaned the little vacuum passage through the intake which was completely clogged. In hindsight, the clogged vacuum was probably the whole problem but as I have to borrow driveway space to work in and my vehicle is my wifes DD, I threw a couple of parts at it as well.

If you pull the intake, do the PHH at the same time, I did and it makes access at least a tad easier!

also:

https://forum.ih8mud.com/showthread.php?t=12498

https://forum.ih8mud.com/showthread.php?t=65702

https://forum.ih8mud.com/showthread.php?t=68445
 

Users who are viewing this thread

Top Bottom