Code P04020

Joined
Nov 8, 2004
Messages
985
Wife just drove the cruiser back from Oak Island, NC. (300miles)
When I went to check out the cruiser the MIL was on.
Got the code pulled and P04020, catalytic converter bank 1.
Had the code cleared drove it home, no MIL.
Drove to work (10miles) no MIL.
Was suggested that I add some SeaFoam to the gas.
Does the code mean I need a new catalytic convert in the near future or is it a bad 02 sensor?
Any advice is greatly appreciated as I have until Friday to pass inspection :crybaby:
 
Joined
Jul 14, 2003
Messages
2,195
Location
Hopewell NJ 08525
 
fzj80kidpen said:
Wife just drove the cruiser back from Oak Island, NC. (300miles)
When I went to check out the cruiser the MIL was on.
Got the code pulled and P04020, catalytic converter bank 1.
Had the code cleared drove it home, no MIL.
Drove to work (10miles) no MIL.
Was suggested that I add some SeaFoam to the gas.
Does the code mean I need a new catalytic convert in the near future or is it a bad 02 sensor?
Any advice is greatly appreciated as I have until Friday to pass inspection :crybaby:
Bad O2s
just drive it around for a few more cycles and if it dosnt come back on run it through inspection.
 

concretejungle

SILVER Star
Joined
Oct 27, 2003
Messages
9,632
Location
North Cadillac
 
 
 
I had that same code. Cleared it out about 5 months ago and haven't seen it agian. I'm wondering if I should replace the O2 sensors anyways? Perhaps they are affecting my gas mileage and the fact that i feel like i'm losing some power during acceleration and highway cruising speed.
 
Joined
Nov 8, 2004
Messages
985
Koffer,
We think alike. Its been cleared twice now and has not come back on yet today.
Concretejungle,
Yea we seem to both agree on the that o2 sensor
 
Joined
Nov 8, 2004
Messages
985
If I do end up replacing the O2 sensor what the deal?
I saw a link for oxygensensors.com and looked them up.
They have Walker and denso. I am assuming the Denso is pretty much OEM but the Walker is about $25 less. Anyone know the diff?
Also what the diff between OE and Universal?
Any advice is greatly appreciated.
 
Joined
Apr 10, 2003
Messages
1,186
Location
Kansas City, MO
 
 
 
My CEL came on last April or May.

Reset the light without checking the code, it came on a few days later.

Checked it the second time, same code.

https://forum.ih8mud.com/showthread.php?t=44602&highlight=code

Read that thread for more info.

I ended up resetting the CEL again (you can do it yourself without a reader by pulling the 15A (?) EFI fuse located in the driverside engine bay fusebox) as both times the CEL light came on shortly after I had driven through deep water. Heavy rains during that time, some partially flooded streets.

It's never come on again, and the Cruiser has been running well getting normal gas mileage the whole time.
 

agomez

Frijoles
Joined
Apr 29, 2005
Messages
1,213
Location
Falkland Islands
 
 
 
According to info I found on the (Toyota tacoma site can't think of the name at the moment), o2 sensors have a life expectancy of about 75k on alot of the toyotas which seems about right already replaced them at 80k and have the code again 165k. Been driving with code for about 8 months with no adverse effects. According to the tech the post cat sensor if bad would not effect economy but pre cat would....??? Maybe a 80 local expert can give some feed back.

Andy
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom