Advice on whether I should buy a Land Cruiser (1 Viewer)

MDarius

I break stuff.
SILVER Star
Joined
Apr 10, 2006
Messages
2,006
Location
Bountiful, UT
Just add the pictures to this thread! We all want to see what happens! This group is good for more than just buying advice! They'll help you maintain it, upgrade it, wreck it, fix it, wreck it again, and keep going! They'll spend all your money, your parent's money, your children's college funds, bail money, and anything you find in the cushions. Keep us updated!
 
Joined
Oct 4, 2020
Messages
83
Location
idaho
Update: stuck at the shop! Everything was good, purchased the vehicle, but at the eleventh hour the engine kept revving up on its own in idle. He just replaced air filter and was tweaking the fan a little. Not sure if it’s the accelerator cable or maybe the carberator/air filter acting up? It just by itself keeps revving higher and higher until we shut it off, started during the test drive but got to the point where I couldn’t leave last night. Guys at the shop are looking at it, even when we pull the accelerator up with our foot it doesn’t fix it or at least only for a split second if even that. Carb? Any advice would be great I need to get this thing on the road today!
 

ntdb

SILVER Star
Joined
Jan 10, 2020
Messages
424
Location
Seattle, WA
FJ60 gurus: Is this potentially a vacuum leak at the carb plate? (Please say yes! Please say yes!)

I had a vacuum leak at the base of my carb last year and it did not behave that way... but who knows. Maybe a vacuum leak higher up on the carb somewhere? It absolutely sounds like a carb problem. Take the air cleaner off and make sure the choke valve isn't closing itself somehow while the RPMs rise.
 

g-man

SILVER Star
Joined
Sep 5, 2006
Messages
2,932
Location
Charlottesville VA
We're going to need a lot more info. What year? what engine? what mods? Images too. Is it a stock carb/air cleaner or some aftermarket stuff. The stock toyota air filter sits over the valve cover and really doesn't come near the carb. The fan has no adjustments...we're talking about the mechanical engine cooling fan. Does your vehicle have electric push fans or aftermarket stuff?

make sure the linkage at the carb moves with the accelerator pedal. And the throttle valve at the bottom of the carb moves with the throttle. Sounds like the linkage is getting hung up, does the pedal move freely back to the up position, Did a spring come off? #10 is the back spring for throttle

1611943949787.png
 

g-man

SILVER Star
Joined
Sep 5, 2006
Messages
2,932
Location
Charlottesville VA
picture of throttle plates (the round brass things with 2 screws inside the black thing actually it's an insulator...primary is the one on top and has the longer shaft that attaches to your throttle linkage coming off the firewall, the secondary shaft is shorter and opens at higher rpms/vacuum.

1611944281055.png
 
Last edited:

g-man

SILVER Star
Joined
Sep 5, 2006
Messages
2,932
Location
Charlottesville VA
Is the primary throttle shaft moving with the accelerator pedal movement? Is the secondary shaft in the correct normally closed position?
 
Joined
Oct 4, 2020
Messages
83
Location
idaho
4BD648DC-3DC8-49E0-8E45-5708B3EC6B9A.jpeg

In Vegas tonight, for 11 hour ahead of me tomorrow to get this pig home. No other option cause I have work Sunday morning and already pushed the trip one day ahead. I’m uploading a Dropbox file for at least the videos Of the things that are concerning me a little. I’ll have some pictures and videos for fun, but I really would love advice on what the engine and carb are doing (see Dropbox file for context) I don’t know how to diagnose the sounds but I believe it’s “pinging” when I throttle all the way down to go much last 45 mph. Especially uphill, thats the first Few videos in the dropBox. Second, the engine revs Itself a little when in idle (Not nearly like before when the vacuum hose wasn’t replaced) so the rpms Kinda fluctuate a little (3rd video). And finally . The carb needs to be tuned I was going to bring it a mechanic shop in ely Nevada, about halfway down the drive to have them tune it for altitude. I’m running rich for sure as the previous owner and shop guys said it does and now I’m rapidly climbing to 6000 feet, fuel was dripping a little out the tail pipe when I was driving around the parking lot, wasn’t doing it earlier I don’t think. I’m running 91 grade fuel. Carberator is stock and engine is stock with an overhaul that happened in 07. I’ll send pictures of the engine bay for further reference. I also stopped tonight because the headlamps and brights are not bright enough for me to feel comfortable.(final photos but don’t do it justice) But that’s more fixable I think (any recs? On lights)
Hopefully that’s enough info, ask questions and I’ll try to answer them, I’m getting up at 6 to start the drive so if you guys recommend Anything maybe I can ask the mechanic in ely, but would probably have to be something fairly simple and quick. Obviously a lot is going well since I’m driving it, it just sucks that I can’t get past about 50 without the thing pinging or making that Rapid clicking sound when I accelerate all the way, it’s also hard to climb inclines becuase of it. I could hit 60/65 when I’m pinging it. I know it’s not a powerful engine but I more than anything else wanna make sure I’m not hurting the engine or anything. That’s why it’s stressing me out a little. Please see sounds in the videos, they filled coolant and oil change before I left.PO said if it’s pinging to not push it. I’m hoping it’s something. Thank you all very much for your interest and advice,
 
Joined
Oct 4, 2020
Messages
83
Location
idaho
View attachment 2569436
In Vegas tonight, for 11 hour ahead of me tomorrow to get this pig home. No other option cause I have work Sunday morning and already pushed the trip one day ahead. I’m uploading a Dropbox file for at least the videos Of the things that are concerning me a little. I’ll have some pictures and videos for fun, but I really would love advice on what the engine and carb are doing (see Dropbox file for context) I don’t know how to diagnose the sounds but I believe it’s “pinging” when I throttle all the way down to go much last 45 mph. Especially uphill, thats the first Few videos in the dropBox. Second, the engine revs Itself a little when in idle (Not nearly like before when the vacuum hose wasn’t replaced) so the rpms Kinda fluctuate a little (3rd video). And finally . The carb needs to be tuned I was going to bring it a mechanic shop in ely Nevada, about halfway down the drive to have them tune it for altitude. I’m running rich for sure as the previous owner and shop guys said it does and now I’m rapidly climbing to 6000 feet, fuel was dripping a little out the tail pipe when I was driving around the parking lot, wasn’t doing it earlier I don’t think. I’m running 91 grade fuel. Carberator is stock and engine is stock with an overhaul that happened in 07. I’ll send pictures of the engine bay for further reference. I also stopped tonight because the headlamps and brights are not bright enough for me to feel comfortable.(final photos but don’t do it justice) But that’s more fixable I think (any recs? On lights)
Hopefully that’s enough info, ask questions and I’ll try to answer them, I’m getting up at 6 to start the drive so if you guys recommend Anything maybe I can ask the mechanic in ely, but would probably have to be something fairly simple and quick. Obviously a lot is going well since I’m driving it, it just sucks that I can’t get past about 50 without the thing pinging or making that Rapid clicking sound when I accelerate all the way, it’s also hard to climb inclines becuase of it. I could hit 60/65 when I’m pinging it. I know it’s not a powerful engine but I more than anything else wanna make sure I’m not hurting the engine or anything. That’s why it’s stressing me out a little. Please see sounds in the videos, they filled coolant and oil change before I left.PO said if it’s pinging to not push it. I’m hoping it’s something. Thank you all very much for your interest and advice,
DROPBOX to videos and photos. Thanks! beehangr cruiser - https://www.dropbox.com/sh/lhgjws1a7113n1p/AACxOIehChkTOtsRChCDutuoa?dl=0
 
Joined
Oct 4, 2020
Messages
83
Location
idaho
More about the rig, have to go to bed but:
guy who I bought it from owns a shop, had a mechanic who new 60s, great dude, worked on it for 2 weeks for me, very fair and genuine (will upload photo of invoices)
Most things are OEM
New battery
Engine temp gauge freeZing it looks like
33 inch mud tires
Rough country suspension (shakes a good amount at 65mph)
Oringila carb
Original engine (overhauled in 2007)

main concerns for rest of drive (in order)
Pings when fully gassing in 4th gear, sometimes only goes 45 others 65. It just doesn’t sound quite right? Maybe the c. (See Dropbox)
Various “Odd” engine noises?(see Dropbox videos)
Some Gas drilling out tailpipe once
Engine temp gauge frozen so I don’t know if it’s overheating. P.O. thought it was fine when I called him( they did coolant and oil yesterday)
cabin smells like gas! Maybe just a missing lid seal for carb?
headlights and brights seem dim hard to see at night

I’m no mechanic yet, I can swing by a shop to get carb tuned or any quick simple tweaks there you guys recommend. But no more than an hour if possible. Hopefully the verdict is keep driving and ignore the pinging but I don’t wanna hurt the engine (OE said pinging isn’t good but then I can’t go above 50)
 

Users who are viewing this thread

Top Bottom