4L60E issues

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, Skimlinks, and others.

Joined
May 4, 2009
Threads
25
Messages
166
Location
Puyallup, WA
Been a while since I've been on mud, because the FJ40 project is almost complete. Got everything together and it runs, drives and stops like a champ, except for one problem, it's not shifting properly.

I have a 2007 5.3 vortec and matching 4L60E, mileage is about 18k. When driving we seem to get no overdrive at all and only the occasional shift or no shift at all. Not sure if it's going into limp mode or what.

Tried changing out the VSS and that didn't make a difference. Scanner revealed that when driving we get the same signal as if at idle. We had the tach and gauges installed by someone else and we have an adapter on the tach, for what I don't know. I'm thinking the issue is that adapter, but I don't have a part number to track it down and see what it actually does for us. I've read that sometimes they are needed and sometimes not needed.

Any of you guys have an idea what else could be my issue?

Posted this in the 40, 60 and 80 sections in hopes more people would see it and chime in.
 
what speed sensor setup are you using?

If the depth is adjustable like mine was (old downey t case adapter) you'll have to set it right.

at first I set it up using silly putty to see how close it was to the reluctor ring, but i finally noticed that it was easier to hook up the scanner to it, stick the t case in neutral, and put the tranny in gear with it running. That allows the reluctor ring to spin while you adjust the depth to get a good signal.
 
Are you running an adapter to the tcase or what? if its not reading a signal and you have the correct pulse vss installed in the proper location ( be it adapter or tailhousing or t case) it is defiantly a problem with your harness or vss location.

Did you start with a 2wd trans? 4wd 4l60es don't have the reluctor ring in place for the advance adapter vss location to pick up a signal as it was originally in the t case instead of the tail housing like a 2wd. If you have a 4wd you need a 2wd output shaft.
 
My VSS is adjustable, and rover, you're a genius. I'm gonna mess with it tomorrow if I can using your idea. I hope that solves it.

Kurtis, I have the correct VSS and I already went through the change out of parts for my 4wd transmission. Shaft swap etc... Just for clarification, I get a signal at idle, but when driving the signal doesn't change. I think I may just need to adjust the VSS again.
 
yeah, I noticed mine could be very finicky. In other words, a bit too far and it'd read weird.

let us know how it works!
 
Made some progress on the tach today and might have found an issue with the speedo that can be fixed fairly easy. There also appears to be 1 wire not running from the tach to the ecm that should be there.
 
seems like you should be seeing some trouble codes too?
 
We have had a few code issues, but they have been resolved. This problem isn't throwing a code for some reason.
 
silly question, but is the transmission taking off in first and not upshifting or could it be taking off in third? i jus had a 62 in the shop that had a conversion done by another cruiser specialist" and it was taking off in third.......

did you get the vss working?
 
I'm starting off in 2nd gear, I think. I get occasional shifts, but no overdrive and you really have to get the RPM's up to force a shift. No luck on the VSS yet. We're working on some potential wiring issues and in a little over a week I'll take it in to the guy who did the wiring to run the scanner on it in depth.

I think our issue may be the tach not sending a signal to the ecu. There is a wire that in the wiring diagram is supposed to go from the tach to the ecu, it's not connected on my tach. The guy who did our wiring talked to speartech, who did our harness, and there was some confusion as to how the tach should be wired. Autometer was helpful in troubleshooting some of our problems and told us how to adjust the pulse signal and that got us a working tach.
 
first thing you have to do is get the vss working.......
 
mine has never thrown a code for the VSS not working for some reason.... which is weird because i never turned that code "off". It must take some crazy conditions to make it set.

As far as the tach signal, the ECU should output the signal to the tach not receive it. There is funkyness on the tach signal... look up "pull up circuit" if you want to read a bunch about it. Basically it needs more of a signal to drive some tachs.

but, I agree with gorge, make sure the VSS is working..
 
yea....I'm sure the VSS has to work regardless of anything else. That would have to be job one. THe trans is electronically shifted so if ECM has no clue if truck is moving or not, then I suspect you will find yourself with a very weird shifting issue. I would not drive it much until VSS fixed.

Even on my truck...VSS made a big difference with engine power, drivability..etc

I would use all GM stuff on the VSS...no aftermarket crap. I too don't recall getting any codes about missing VSS, but I run a manual trans and my computer has been reprogrammed to address many of hte missing items. It may depend on how the ECM is modfied...but regardless the VSS has to work or you've got problems that I don't think can be fixed otherwise.
 

Users who are viewing this thread

Back
Top Bottom