VSC trac, VSC off and trac light on

Joined
Mar 15, 2019
Messages
75
Location
Nor Cal
After lifting the 470 and getting alignment done the VSC trac, VSC off and trac light came on. The scangauge does not show any CEL codes. What would be causing the lights to come on?

5AC36F36-2287-43FD-9F08-5BE87952013C.jpeg
 
Joined
Feb 4, 2004
Messages
47
I had same issue but my code reader said it was the gas cap. I put a new OEM cap on and took steel wool to the steel gas filler that the cap screws into because it had super small pits where the gas cap rubber gasket makes contact with the steel filler.
Cleared the warning lights and no problems since

Cheers Baja Charlie
 
Joined
Mar 15, 2019
Messages
75
Location
Nor Cal
I did some research and all points to either a defective ABS sensor or need to do a ZPC (zero point calibration). Going to have my buddy hook up his scanner this weekend to confirm.
 
Joined
Jun 17, 2019
Messages
46
Location
New Mexico
I had same issue but my code reader said it was the gas cap. I put a new OEM cap on and took steel wool to the steel gas filler that the cap screws into because it had super small pits where the gas cap rubber gasket makes contact with the steel filler.
Cleared the warning lights and no problems since

Cheers Baja Charlie
I had the same issue and same solution.
 
Joined
Mar 15, 2019
Messages
75
Location
Nor Cal
How did you lift it?

I swapped the full suspension setup (kings ext travel fronts and kings LT rear with MT HD springs and 4 link adj rods) from my 05 4r to the 470. For some reason I went to get gas this afternoon and the lights somehow never came back on, same thing on my way home from work. It was only on when I went to work this morning. I will monitor it for the next few weeks while I’m breaking in the front gears.
 

Users who are viewing this thread

Top Bottom