TPMS diagnosis (TechStream)

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, Skimlinks, and others.

Apr 16, 2010
Spring Branch, TX
My TPMS dash light has been on for several months.
Yesterday took '06 LX470 to trusted tire shop. Shop owner was concerned because all 5 sensors on the truck appeared inoperable - he stated he rarely/never sees that.
They replaced all 5 sensors. But dash light stayed on.
Tire guy suggested I drive it for a while and bring it back if light doesn't go out.
So far, light hasn't gone out.

Does the attached tech stream screen shot below offer any clues to what my problem might be (I have no idea what I'm looking at)?


What brand sensors did the tire shop install? If they used aftermarket programmable one's, they should have programmed the 7 digit code from your original set to your new one's. If they used new oem, they should have registered them with their handheld programmer. If they used new oem or denso sensors and if you have pictures of all 5 of the 7 digit codes, you should be able to program them yourself in techstream.
Talked to tire guy. He's not concerned. I'll bring it back next week and let him reprogram...

Just after the above posts, I received the sensor IDs and entered them in via Techstream - was easier than bring LX back to him. The blinking warning light immediately went away and everything's been fine.

This weekend, it came back on. Hooked up the Techstream, and the errors look same as before, except the correct ID codes (the ones I entered) are there.

Tire guy, who I've used for >10 years and trust, said they were aftermarket, but Japanese (not Chinese) sensors. He said they'd had perfect reliability with them. For whatever that's worth.

Anyone have any idea on what might be going on here?

Many thanks!

Also... I have no idea if this is relevant (showing some error/malfunction with the vehicle???)... But, the Techstream error out when I try to look at "some" of the TPMS data/options.

I've tried with two different machines but get the same errors on both.

I'm running into this exact problem now. ID1 Pressure N/A. Les Schwab replaced a sensor and "relearned" the sensors and gave me the car back. Light still on.

I drove it for a day, tried to reset, no luck. Pulled out techstream and the same problem still exists. No measurement from ID1. I get the same error code if I try to run the signal check utility. The tire shop has no idea what the code was because "they have a machine that works on all cars on the planet" so they don't bother with the codes. Upon pressing for answers they say they were unable to read any of the sensors and thought they were all bad. Even though they charged me for a new sensor and for the "TPMS relearn" labor. God, I hate paying other people to do car work (usually very poorly, like this).

Anyone know how to get the ID programmed any other way?
Mine ended up being the wrong sensors. Once I got the right ones, the process worked like clockwork...
Mine ended up being the wrong sensors. Once I got the right ones, the process worked like clockwork...
Awesome. Thank you. I can see that being the case for me as well. The shop seems to be a little flustered or careless. If they can't get it right, I'll order up a genuine sensor myself and have the dealer do it.
Originally, I bought p/n 550-0191, but those didn't work either.

Finally, got p/n 550-0103, and they worked immediately.
Amazon product

IIRC, the confusion had something to do with my month (in 2006) of manufacture. 2006 LX470.

Good luck.
Mine ended up being the wrong sensors. Once I got the right ones, the process worked like clockwork...

What Brand sensors did you get? I need a set.

Users who are viewing this thread

Top Bottom