1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Still idles rough

Discussion in '80-Series Tech' started by nyk438, Feb 29, 2004.

  1. nyk438

    nyk438 Guest

    My 80 is still idling rough. I don't know what it is. I shorted out the alternator when going through a mud pit. As I remember it idled bad right after the pit, I put in a weaker rebuilt alternator and was wondering if this could still be it? I checked, there aren't any hoses or anything disconnected when I installed the rebuilt alt., I changed the air filter, still idles bad...When I turn teh A/C on it'll idle at 1k rpms and not shake very much at all....wtf is wrong with my truck! It runs like a beast just the shakiness is getting annoying...
     
  2. IdahoDoug

    IdahoDoug

    Messages:
    8,848
    Likes Received:
    238
    Joined:
    Aug 9, 2003
    What do you mean "shorted out the alternator"? This is virtually impossible to do, so I'm wondering if you had some other type of electrical gremlin. What normally happens to alternators bathing in mud is the thing simply gets packed with mud and won't work right unless it's properly cleaned as the contacts are not making contact. Usually a month after its' been cleaned to work properly, then the bearings go.

    DougM
     
  3. Beowulf

    Beowulf

    Messages:
    12,530
    Likes Received:
    48
    Joined:
    Mar 27, 2003
    Location:
    Somewhere in the foothills...
    Nic,

    You need to do basic problem isolation for an engine misfire. You should know the drill by now. Check wiring (plug & coil.) Plugs, vacuum leaks, PCV, hose from air cleaner to intake, etc.

    -B-
     
  4. nyk438

    nyk438 Guest

    Yeah guess I need to check again. For the alternator I took it to an alternator shop and they said it was totally dead....