For Sale PAIR Valve Assembly from 94 FZJ80 (1 Viewer)

Joined
Sep 7, 2017
Messages
32
Location
Jerome, AZ
Complete and perfectly working PAIR valve assembly from a 1994 FZJ80 4.5 liter with only 132k on the odometer. Intake hose is dry and slightly cracking as it is original. Vacuum hose is brand new oem toyota. Looking for $70 dollars plus shipping from Arizona, or local pickup.

100_1757.JPG


100_1758.JPG
 
Joined
Sep 14, 2020
Messages
29
Location
Ridgway Colorado
Complete and perfectly working PAIR valve assembly from a 1994 FZJ80 4.5 liter with only 132k on the odometer. Intake hose is dry and slightly cracking as it is original. Vacuum hose is brand new oem toyota. Looking for $70 dollars plus shipping from Arizona, or local pickup.

View attachment 2383119

View attachment 2383120
Hello, Do you by chance still have this pair system? I only need the valve box. Thank you
 
Joined
Sep 14, 2020
Messages
29
Location
Ridgway Colorado
My apologies, I forgot to respond. After speaking with a few more people, I do not think the pair valve is my problem. I am however going to try and do a few more things before I replace it. I'll be in touch. I appreciate your time.
 
Joined
Sep 7, 2017
Messages
32
Location
Jerome, AZ
My apologies, I forgot to respond. After speaking with a few more people, I do not think the pair valve is my problem. I am however going to try and do a few more things before I replace it. I'll be in touch. I appreciate your time.
What are your Landcruiser symptoms?
 
Joined
Sep 14, 2020
Messages
29
Location
Ridgway Colorado
What are your Landcruiser symptoms?
It’s a miss at idle. I’ve thrown every potential part
What are your Landcruiser symptoms?
I have a miss at idle, and an occasional OBD1 code 25 (running lean) at idle that goes away a minute or two once start driving and pick up speed.
I've thrown every part I can think of at it with no resolution. I'm left at valves needing adjustment and injectors. Here's what I've done already: 99% OEM parts
SPARK PLUGS (Gap Checked)
IGNITION COIL
SPARK PLUG WIRES
DISTRIBUTOR CAP & SEAL
DISTRIBUTOR ROTOR
FUEL PRESSURE REGULATOR / O-RING
IDLE AIR CONTROL VALVE & O-RING
VAF REPLACED WITH REBUILT
INTAKE AIR HOSE
PCV VALVE
50% REPLACEMENT OF VACUUM HOSES
OXYGEN SENSORS REPLACED (2)
FUEL FILTER
OIL FILLER CAP
THROTTLE POSITION SENSOR
TIMING CHECKED (4 DEGREES)
SMOKE TESTED VACUUM LINES AT INTAKE (NO LEAKS FOUND)
EGR VALVE CLEANED-TESTED
IDLE CONTROL VALVE PORT CLEANED
EGR MANIFOLD PORT CLEANED
IDLE AIR CONTROL PORT CLEANED
 
Joined
Sep 7, 2017
Messages
32
Location
Jerome, AZ
It’s a miss at idle. I’ve thrown every potential part

I have a miss at idle, and an occasional OBD1 code 25 (running lean) at idle that goes away a minute or two once start driving and pick up speed.
I've thrown every part I can think of at it with no resolution. I'm left at valves needing adjustment and injectors. Here's what I've done already: 99% OEM parts
SPARK PLUGS (Gap Checked)
IGNITION COIL
SPARK PLUG WIRES
DISTRIBUTOR CAP & SEAL
DISTRIBUTOR ROTOR
FUEL PRESSURE REGULATOR / O-RING
IDLE AIR CONTROL VALVE & O-RING
VAF REPLACED WITH REBUILT
INTAKE AIR HOSE
PCV VALVE
50% REPLACEMENT OF VACUUM HOSES
OXYGEN SENSORS REPLACED (2)
FUEL FILTER
OIL FILLER CAP
THROTTLE POSITION SENSOR
TIMING CHECKED (4 DEGREES)
SMOKE TESTED VACUUM LINES AT INTAKE (NO LEAKS FOUND)
EGR VALVE CLEANED-TESTED
IDLE CONTROL VALVE PORT CLEANED
EGR MANIFOLD PORT CLEANED
IDLE AIR CONTROL PORT CLEANED
I'll send you a private message to keep this thread on track....
 

Users who are viewing this thread

Top Bottom