Fuel pump/relays REAL TIME HELP!!!!!!!!

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, Skimlinks, and others.


Aug 4, 2004
central CT
Here's the deal. Previously I have had trouble with my 88 mini not starting on cold mornings only. I placed a jumper in Fp and B+ in the diagnostic port and after a minute or so, the fuel pump would get power and the truck would start. Off to work I would go. This worked about 40 or 50 times no problem. Well, this morning, nothing. Ok, pulled my bed, checked wires again to fuel pump. No power. Put in jumper, no power. Removed battery, hooked up direct to fuel pump, fuel pump kicked on. OK, either a relay or short. Removed relays, checked continuity, everything seems ok. Although I have a crappy meter and I can't read ohm values. I spent hours fooling around with the relays, meter, battery and so on. Could not get constant power to fuel pump, but the pump always worked with the battery hardwired to it. Sometimes I would get power with the jumper in, other times nothing.

From this point I went to the parts store, bought wire and hardwired the pump up to a toggle switch. Figured this would solve my problems. Nope, engine won't stay running with the fuel pump on all the time for some reason. Please help. Should I buy a new fuel pump and see what happens? I don't understand why this would work because mine works fine hardwired to the battery. Or is it a relay? I wired the EFI relay to the battery and could hear it click, sounded operational. I also followed all the diagnostic checks for the two relays (efi &cor) in the Haynes manual. I really need this fixed as I can not get to work. Took today off figuring it was just the fuel pump, but now I'm stumped with my truck in pieces in the driveway and no way to get to work. Thanks for any and all suggestions. :eek::confused::confused:
That really sucks, sounds like you're on the right path though. When you turn the ignition switch to the on position (right before cranking but NOT running yet) do you see the "check engine" light? If the light's not on then the EFI computer has no power. I don't know the Haynes procedures for checking the relay (sorry, you might have already checked this) but does the procedure have you confirm that power is traveling out of the relay? I had this problem in my 80, the relay worked (clicking noise) but power was not leaving the relay.

Good luck dude!:D
So I just went out to look and no light. I had the ECU unbolted, not sure if it needs to be bolted to be grounded, don't think so, but anyway, placed the ecu where it bolts, turned on the key and the eng light came on. No power to pump. Put in jumper, pump buzzed, tried to start, wouldn't fire. Cycled the key again and no light. Is the fuel injection computer the same as the ECU? Under the pass side kick panel?

And yeah, I know, I need a FSM for this vehicle. Picked the Haynes up at a flea market. My cheap a** hasn't found one that will fit my budget yet. How do you check the output power of the relays? The Haynes manual described how to check for continuity and take ohm readings but my meter doesn't give me an actual ohm reading, the needle just pins to the other side. Thanks, I appreciate the help. I'm totally clueless as where to go next. And running out of daylight. :frown:
Can you check to see if there is power coming out of the relay? I just talked to a friend today who said he just fixed a 90 4Runner with a bunch of odd drivability problems by changing the fuel pump. Seems the old one was still working, but not putting out the pressure the engine needed.....

Sounds like the relay is the problem to me... cut it open and see if you can clean the contacts up! :D
Other than what the others have metioned...(sounds like a poor pump).

But, would a poor alt, or weak battery effect this? Check all grounds.

Josh, I will be in Manchester later in the am, if you need a hand or a ride to get parts...LMK.
Call me.
I don't have a pic here at work but you can make some jumpers with flat wire connectors (proper term may be "spade"). With four jumer wires you can connect the relay outside of the fuse box for easier testing. The same test jumpers can connect a diffrent replacement relay, I think the factory one is 15 amps. Most generic lighting relays are 30 amps, not a clean fix but very fast. This is tough for me to describe, I'll get pics soon.
If you pull the relay small jumper wires can be connected to test it. I'd double check the jumper wires with a meter to be sure the connections are right. Then you can verify the relay is putting out power, maybe shake it a bit to see if anything changes. If you need to use another relay it's not hard to connect. This is how I hooked a 30 amp relay to the factory plug. These pictures suck, I'd verify the replacement relay's connections if the marks are tough to read.
relay 2.jpg
relay 3.jpg
Thanks for all the help everyone. It ended up being a leak where the cowell and the inner fenderwell meet. The water would leak onto the fuse block on the DS kick panel. When it would freeze, no connection. I assume that it finally blew the EFI relay. I heard the relay clicking, but I assume power was not going through it.

Luckily, the mechanic at work had an EFI relay kickin around (we don't even have Toyota's at work). I figured I would bring it home and start with what was free for process of elimination. When I went to put it in, I noticed that the fuse block had ice in it. Low and behold I found areas the PO had siliconed. Gave me a chance to use my new Hobart Handler 187. All fixed and runnin.

Sorry for the delay, but I rarely have time for the computer anymore. Startin a business comsumes all my time.

And Sam, thanks for the offer. I did see it Thurs am, but my boss threw a fit and demanded me to show up to work. Didn't get to work on her till Sat.
Good catch, I leak water in the cab there too but have parts in different places. Might be time to burn some metal here, just in case. Congratulations again! :cheers:

Users who are viewing this thread

Top Bottom