EGR CAT I/M blinking red no codes

Joined
Apr 18, 2019
Messages
25
Location
Los angeles
just got a ‘96 LC with 275k miles. CEL (P0402 and P0325) was on when I purchased from PO. Changed CAT ( front and rear), knock sensor, and EGR valve. I’ve been driving her around (40-60 miles) and so far no more CEL, but when I plug in my obd2 (innova 3100) there is no DTC/ freeze frame data stored in ECU, but i/m monitor shows blinking red CAT and EGR. Will this pass smog in CA?
 
Joined
Dec 8, 2006
Messages
10,881
Location
New Jersey
Website
www.sdsysdesign.com
Remove the 15 amp EFI MAIN fuse in the fuse box on the left fender for about 10 minutes. That should clear out all stored codes and force the ECU to re-learn all sensors. Your idle should be higher and you may notice some other irregularities until you've completed a few drive cycles.
 
Joined
Apr 18, 2019
Messages
25
Location
Los angeles
Remove the 15 amp EFI MAIN fuse in the fuse box on the left fender for about 10 minutes. That should clear out all stored codes and force the ECU to re-learn all sensors. Your idle should be higher and you may notice some other irregularities until you've completed a few drive cycles.
Thanks for the input. Just to clarify. Do I remove and drive for 10 minutes? Remove and let car run for 10min? and then re-install?
 
Joined
Apr 18, 2019
Messages
25
Location
Los angeles
U plugged EFI Main for 10min. Started 1st drive cycle. CEL came back on with P0325. I/M monitoring for CAT, EGR, HTR, and 02
 
Joined
Dec 8, 2006
Messages
10,881
Location
New Jersey
Website
www.sdsysdesign.com
U plugged EFI Main for 10min. Started 1st drive cycle. CEL came back on with P0325. I/M monitoring for CAT, EGR, HTR, and 02
PO325 is knock sensor #1. You will notice poor gas mileage and lack of power as the ECU has retarded timing to max.
All information is in the Toyota Factory Service Manual (FSM) available to download in the resources section.
 

Users who are viewing this thread

Top Bottom