Both rear turn signals are out!! Looking for mechanic recommendations. (1 Viewer)

Beej

SILVER Star
Joined
Apr 13, 2016
Messages
907
Location
Phoenix, AZ
Hey folks,

I have some electrical issues. I've replaced both tail light harnesses, tried bulbs and fuses but can't seem to end this problem.

Any recommendations on mechanics or last ditch checks to fix the issue?

Thanks in advance for any replies. This is my daily driver so unfortunately I need a quick-ish fix :crybaby:

-- Beej
 
Joined
Oct 25, 2007
Messages
1,357
Location
Surprise AZ.
If you are on the west side go to NASA auto electric, 6132 W. Glendale. I have known him for almost 25 years and he knows what he is doing. Many of the local dealers use him when they can't diagnose a problem. In the cases I have brought mine to him he tells me what is wrong before he opens the hood.

Tell him Mark from the City of Glendale sent you. PM me if you have any other questions.
 
Joined
Jun 29, 2011
Messages
3,229
Location
Phoenix, AZ
Front signals work fine, hazards all work and only rear turn signals are faulty? If that is accurate I would suspect the flasher relay or possibly bad grounds, but on both lights that seems unlikely.
 

GBinAZ

SILVER Star
Joined
Feb 24, 2009
Messages
609
Location
Gilbert, AZ
Call Eric Murphy the service director at Camelback Toyota if you're close to 16th St and Camelback.

Murf is his name here on Mud if you're not familiar with him.
 

Beej

SILVER Star
Joined
Apr 13, 2016
Messages
907
Location
Phoenix, AZ
Rear subharness was cracked and corroded. There was bad grounding and more. Murf got it taken care of. I may still purchase the whole harness at some point but for now she's good.
 
Joined
Apr 21, 2005
Messages
19,606
Rear subharness was cracked and corroded. There was bad grounding and more. Murf got it taken care of. I may still purchase the whole harness at some point but for now she's good.

Did the cruiser come from Western MA? Different parts of the country seem to have their set of problems. For the most part wiring is not one of them here in my experience.
 

Beej

SILVER Star
Joined
Apr 13, 2016
Messages
907
Location
Phoenix, AZ
Did the cruiser come from Western MA? Different parts of the country seem to have their set of problems. For the most part wiring is not one of them here in my experience.

Yes sir, it did! That was my hypothesis too. Too much trauma from road grime and similar.
 

Users who are viewing this thread

Top Bottom