Anyone know of MFD issue for 2006 LX470 ? (1 Viewer)

Joined
Oct 30, 2013
Messages
2
From what I've read here, the issues are up through MY 2004's, is that right?

I have a MY 2006 LX470...just rolled over 230K miles today and literally the same day my MFD screen did something I had never seen before: I normally keep the MFD on the trip computer to show MPG & estimated range and all of a sudden the screen flashed to Lexus like it was restarting itself which I had never seen it do before. Once the display came back to life the tank MPG was still displaying but the estimate range was blanked out with no numbers there. It then proceeded to cycle through this process every few minutes where the screen would reset back to Lexus and then back again.

Despite that, the climate controls and the radio was all working fine, but then on one of those cycles I described above, the entire MFD went dark and my climate control system shut off for just about 2-3 seconds before everything came back to life at the Lexus screen.

It seems like my MFD is on the verge of failure. Anyone experience this before?
 
Joined
May 20, 2019
Messages
1,277
Location
Lost Wages
I would check the connectors on the back first, reseat them and make sure no rust/moisture damage on any pins or connectors.
 
Joined
Oct 30, 2013
Messages
2
I would check the connectors on the back first, reseat them and make sure no rust/moisture damage on any pins or connectors.

Thanks. If this continues (which I assume it will) then I was thinking about doing exactly what you had suggested.
 

Users who are viewing this thread

Top Bottom