Voltage issues (1 Viewer)

Joined
Nov 16, 2012
Messages
34
Location
Lafayette, Louisiana
Freeking electrical.

I am so envious of you guys that get electrical. So I have a sbc swap in a 76 40. I installed a fast fuel injection system (whole nuther discussion) the fuel injection system comes with a read out of the voltage. On start up running 12.5. When the electrical cooling fan kicks on drops to 11.5. I have a yellow top battery about 2 years old and just installed a 140amp alt. no change. My question is could the voltage regulator be affecting this. Could I or should I bypass the vr since the new alternator are internally regulated. The low voltage is causing some issues with the fuel injection system among other things.
 
Joined
Dec 7, 2011
Messages
479
Location
Middle Tennessee
Have you charged the battery fully overnight and gotten a fully charged voltage reading? It should be about 13.2 if the battery is healthy.
 
Joined
Mar 31, 2005
Messages
639
Location
Citrus Springs, Florida
How much current (amps) does the cooling fan pull?

Did you upgrade the cable from the 140 amp alternator to the battery? Too small of cable will drop a lot of current through it.

Where does your voltage meter read from, the battery, or elsewhere?

Does the alternator have a larger ground cable?


Jerry D.
 

RAYJON

Get a bigger hammer..
Joined
Oct 20, 2005
Messages
1,844
Location
Reno NV
what 140amp alt did you install, the cs144's are 100amps at idle and will run 14.8 volts, you have to wire them correctly with a resistor or light in the sensing wire but other than that they are great, a 140amp SI style alternator will only put out about 30-50amps at idle and wont support fuel injection and electric fans... good luck
 

Users who are viewing this thread

Top Bottom