New to San Antonio (1 Viewer)

Joined
Apr 15, 2012
Messages
11
Location
San Antonio, TX
Hello everyone. I just moved to San Antonio from Spokane WA. I currently am a Tundra and FJ40 owner but owned FJ80, FJ62 and FJ Cruiser over the years. Hope to see people out there eventually.

I also have a question. My FJ40 radiator isn't cutting it in this heat with a 350. I know I will need a monster radiator with fans/shroud probably and could use some advise on where to go. Thanks.

James
 
Joined
Dec 16, 2007
Messages
1,226
Location
San Antonio, Tx
how old is your factory radiator? i've seen several people running factory fj40 radiators and no cooling problems with proper shrouding or electric fans. If your radiator is getting older, like 10-15 years or older then its probably not working as good as it used to and can't cool the 350. Let me know if I can help.
 
Joined
Apr 15, 2012
Messages
11
Location
San Antonio, TX
The radiator is brand new, but lacks a shroud or fans.

I have bigger problems now. My truck almost burned to the ground. With switching fire extinguisher for wrench I was able to keep it from flaming while disconnecting the battery. For some reason while in park and keys out, the starter started as a very high RPM and burned all the wires connected in it bundle. It is now sitting until I can find some place to have her towed. Any suggestions would be greatly appreciated. Just about everything under the hood is brand new with less than 600-700 miles. Not sure if in the motor install a wire got exposed or what. I am not very mechanical. Thank you.
 

Users who are viewing this thread

Top Bottom